Bug 227531 - devel/qca: update failure: pkg-static: Unable to access file: No such file or directory
Summary: devel/qca: update failure: pkg-static: Unable to access file: No such file o...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-kde (Team)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-04-15 19:34 UTC by O. Hartmann
Modified: 2018-10-27 06:03 UTC (History)
4 users (show)

See Also:
tcberner: maintainer-feedback+


Attachments
List of installed ports (25.40 KB, text/plain)
2018-05-26 20:08 UTC, Valeriy
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description O. Hartmann 2018-04-15 19:34:14 UTC
Updating and installation of port devel/qca fails with the following error:


[...]
===>>> All >> baloo-kde4-4.14.3_8 >> kdepimlibs-kde4-4.14.10_18 >> kdelibs-kde4-4.14.38_2 >> devel/qca (4/22)

===>  Installing for qca-qt4-2.1.3_1
===>   Registering installation for qca-qt4-2.1.3_1 as automatic
pkg-static: Unable to access file /usr/ports/devel/qca/work-qt4/stage/usr/local/bin/mozcerts:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/qca/work-qt4/stage/usr/local/bin/qcatool:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/qca/work-qt4/stage/usr/local/include/QtCrypto/QtCrypto:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/qca/work-qt4/stage/usr/local/include/QtCrypto/qca.h:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/qca/work-qt4/stage/usr/local/include/QtCrypto/qca_basic.h:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/qca/work-qt4/stage/usr/local/include/QtCrypto/qca_cert.h:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/qca/work-qt4/stage/usr/local/include/QtCrypto/qca_core.h:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/qca/work-qt4/stage/usr/local/include/QtCrypto/qca_export.h:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/qca/work-qt4/stage/usr/local/include/QtCrypto/qca_keystore.h:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/qca/work-qt4/stage/usr/local/include/QtCrypto/qca_publickey.h:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/qca/work-qt4/stage/usr/local/include/QtCrypto/qca_safetimer.h:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/qca/work-qt4/stage/usr/local/include/QtCrypto/qca_securelayer.h:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/qca/work-qt4/stage/usr/local/include/QtCrypto/qca_securemessage.h:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/qca/work-qt4/stage/usr/local/include/QtCrypto/qca_support.h:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/qca/work-qt4/stage/usr/local/include/QtCrypto/qca_textfilter.h:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/qca/work-qt4/stage/usr/local/include/QtCrypto/qca_tools.h:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/qca/work-qt4/stage/usr/local/include/QtCrypto/qca_version.h:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/qca/work-qt4/stage/usr/local/include/QtCrypto/qcaprovider.h:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/qca/work-qt4/stage/usr/local/include/QtCrypto/qpipe.h:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/qca/work-qt4/stage/usr/local/lib/cmake/Qca/QcaConfig.cmake:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/qca/work-qt4/stage/usr/local/lib/cmake/Qca/QcaConfigVersion.cmake:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/qca/work-qt4/stage/usr/local/lib/cmake/Qca/QcaTargets-release.cmake:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/qca/work-qt4/stage/usr/local/lib/cmake/Qca/QcaTargets.cmake:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/qca/work-qt4/stage/usr/local/lib/libqca.so:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/qca/work-qt4/stage/usr/local/lib/libqca.so.2:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/qca/work-qt4/stage/usr/local/lib/libqca.so.2.1.3:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/qca/work-qt4/stage/usr/local/lib/qca/crypto/libqca-cyrus-sasl.so:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/qca/work-qt4/stage/usr/local/lib/qca/crypto/libqca-gnupg.so:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/qca/work-qt4/stage/usr/local/lib/qca/crypto/libqca-ossl.so:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/qca/work-qt4/stage/usr/local/libdata/pkgconfig/qca2.pc:No such file or directory
pkg-static: Unable to access file /usr/ports/devel/qca/work-qt4/stage/usr/local/man/man1/qcatool.1.gz:No such file or directory
*** Error code 74

Stop.
make[1]: stopped in /usr/ports/devel/qca
*** Error code 1
Comment 1 Tobias C. Berner freebsd_committer 2018-04-15 19:53:29 UTC
Hm, I cannot reproduce this here. 

mfg Tobias
Comment 2 Tobias C. Berner freebsd_committer 2018-05-06 18:20:06 UTC
Hi there,

Do you have some more information? that could help us to reproduce it? Or has the problem disappeared?


mfg Tobias
Comment 3 cn1337 2018-05-08 08:57:52 UTC
I had the same issue using portmaster. 

I did a 'pkg delete kdelibs-kde4' since only sysutils/k3b required it.

I reinstalled k3b after, which makes you build a bunch of (new?) dependencies besides kdelibs-kde4.

Worked for me. Try it if you have k3b installed.
Comment 4 Valeriy 2018-05-26 20:08:15 UTC
Created attachment 193728 [details]
List of installed ports
Comment 5 Valeriy 2018-05-26 20:18:08 UTC
I encountered the same issue.
Steps to reproduce.
1. # portmaster –clean-distfiles
2. # pkg clean
3. # pkg update (I didn't do # pkg upgrade)
4. # portsnap fetch update
5. # portmaster -aRfdB –no-confirm
Result: The reported error. When checked directory /usr/ports/dev el/qca/work-qt4 didn't actually exist,
6. # cd /usr/ports/devel/qca
7. # make deinstall
8. # make install
Result: Now directory /usr/ports/devel/qca/work-qt4 does exist, all files listed in the error message can be seen there. (See the list of installed ports at this point attached).
9. # portmaster -aRfdB –no-confirm
Result: Process stops with the same error as initially reported, directory /usr/ports/devel/qca/work-qt4 does NOT exist anymore.
Comment 6 Valeriy 2018-05-27 00:09:18 UTC
Rebuilding # portmaster archivers/ark-kde4 re-installs qca and results in the issue reported.

===>>> ark-kde4-4.14.3_4 >> (7)

===>>> The following actions will be taken if you choose to proceed:
        Upgrade ark-kde4-4.14.3_4 to ark-kde4-4.14.3_5
        Upgrade kdelibs-kde4-4.14.38_1 to kdelibs-kde4-4.14.38_3
        Re-install qca-qt4-2.1.3_1
        Install sysutils/polkit-qt@qt4
        Upgrade polkit-0.113_5 to polkit-0.114
        Install lang/spidermonkey52
        Install devel/autoconf213
        Upgrade enchant-1.6.0_7 to enchant-1.6.0_8
Comment 7 commit-hook freebsd_committer 2018-05-28 19:34:30 UTC
A commit references this bug:

Author: adridg
Date: Mon May 28 19:34:04 UTC 2018
New revision: 471064
URL: https://svnweb.freebsd.org/changeset/ports/471064

Log:
  Since devel/qca was flavorized, kdelibs-kde4 was still depending on
  the unflavored, and now Qt5-by-default-version. Make the required
  flavor explicit.

  PR:		227531
  Reported by:	ohartmann@walstatt.org

Changes:
  head/x11/kdelibs-kde4/Makefile
Comment 8 Adriaan de Groot freebsd_committer 2018-05-28 19:56:03 UTC
I couldn't reproduce the problem here, probably because I'm doing a build in a clean environment. But the commit referenced here does reduce the amount of Qt5 dependencies, and ensures that the qt4 flavor is being built.

Please try again with current ports tree.
Comment 9 Tobias C. Berner freebsd_committer 2018-10-20 18:44:34 UTC
Moin moin 

is this still an issue?


mfg Tobias
Comment 10 O. Hartmann 2018-10-27 06:03:49 UTC
(In reply to Tobias C. Berner from comment #9)
This problem has been solved. It seems (at least for me), that the port builds on 12-BETA1 and 13-CURRENT as expected.