Bug 227641 - drill(1) contains typo - "loopup"
Summary: drill(1) contains typo - "loopup"
Status: Closed FIXED
Alias: None
Product: Documentation
Classification: Unclassified
Component: Manual Pages (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-04-19 15:39 UTC by Rebecca Cran
Modified: 2019-11-06 18:13 UTC (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rebecca Cran freebsd_committer 2018-04-19 15:39:26 UTC
The drill(1) man page contains a typo for the -x option:

       -x     Do a reverse loopup. The type argument is not used, it is preset
              to PTR.

"loopup" should be "lookup".
Comment 1 Oleksandr Tymoshenko freebsd_committer freebsd_triage 2018-04-20 20:45:57 UTC
This is a contrib code, I believe the policy for contrib software is to merge fixes from upstream unless they're FreeBSD-specific. These typos were fixed in the upstream repo: https://github.com/NLnetLabs/ldns/commit/d1f8720ab88dd59a8007345aec4fe5aea9b4aff0#diff-f3ba2a96072b04d256a347403eff94e9
Comment 2 Andras Farkas 2018-05-24 11:39:41 UTC
(In reply to Oleksandr Tymoshenko from comment #1)
Those typos were fixed upstream in 2015. Clearly, this upstream fix never made it to FreeBSD.
Comment 3 Mark Johnston freebsd_committer 2018-05-24 13:08:57 UTC
This was fixed in the LDNS import earlier this month: r333551.
Comment 4 Mark Johnston freebsd_committer 2018-05-24 13:13:32 UTC
Not sure if DES is planning on merging the LDNS update into 11.2. The issue is fixed only in HEAD at the moment.
Comment 5 Andras Farkas 2019-11-06 16:10:07 UTC
This is fixed, at least in FreeBSD 12.1-RELEASE