Bug 227685 - graphics/mesa-dri: update to 18.1.0
Summary: graphics/mesa-dri: update to 18.1.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-x11 mailing list
URL: https://www.mesa3d.org/relnotes/18.1....
Keywords: patch
Depends on: 225415 227678
Blocks: 223014 230298
  Show dependency treegraph
 
Reported: 2018-04-22 06:16 UTC by Jan Beich
Modified: 2018-08-02 18:01 UTC (History)
5 users (show)

See Also:
bugzilla: maintainer-feedback? (x11)


Attachments
rc1 (4.60 KB, patch)
2018-04-22 06:27 UTC, Jan Beich
no flags Details | Diff
rc2 (5.04 KB, patch)
2018-04-27 23:46 UTC, Jan Beich
no flags Details | Diff
rc2 (rebased after ports r468593) (4.65 KB, patch)
2018-04-28 20:59 UTC, Jan Beich
no flags Details | Diff
rc3 (4.65 KB, patch)
2018-05-04 19:47 UTC, Jan Beich
no flags Details | Diff
rc4 (4.65 KB, patch)
2018-05-12 10:26 UTC, Jan Beich
no flags Details | Diff
Update graphics/mesa-dri and graphics/mesa-libs to 18.1.0 (4.59 KB, patch)
2018-05-19 22:18 UTC, Niclas Zeising
no flags Details | Diff
Update graphics/mesa-dri and graphics/mesa-libs to 18.1.0 (7.45 KB, patch)
2018-05-20 10:07 UTC, Niclas Zeising
no flags Details | Diff
glxinfo-mesa-18.1.0.txt (25.20 KB, text/plain)
2018-05-29 18:32 UTC, Carlos J. Puga Medina
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2018-04-22 06:16:51 UTC

    
Comment 3 Jan Beich freebsd_committer 2018-04-28 20:59:05 UTC
Created attachment 192884 [details]
rc2 (rebased after ports r468593)
Comment 6 Niclas Zeising freebsd_committer 2018-05-19 08:58:31 UTC
Looking at this.
Comment 7 Jan Beich freebsd_committer 2018-05-19 18:49:26 UTC
(In reply to Niclas Zeising from comment #6)
> Looking at this.

Beware, I have no plan to wait on x11@ anymore after numerious cases of cookie licking. Whatever happens on semi-private venues (e.g., IRC channels) can be ignored unless there're public logs.
Comment 8 Adam Weinberger freebsd_committer 2018-05-19 21:51:59 UTC
I share jbeich's frustration. This PR has been open for a month with no response, but now it's technically in an indefinite "hold."

Jan, please give Niclas the benefit of the doubt here and allow the x11 team another week to review it before committing it under a timeout.

The x11 team is chronically short-staffed. Jan, I urge you to consider joining the x11 team. It'd remove any ambiguity about timeouts, and would be a huge benefit for the x11 project.
Comment 9 Greg V 2018-05-19 22:14:11 UTC
+1, would love to see another x11 committer

By the way, the new public (& logged) chat room is https://gitter.im/FreeBSDDesktop/Lobby
Comment 10 Niclas Zeising freebsd_committer 2018-05-19 22:18:17 UTC
Created attachment 193545 [details]
Update graphics/mesa-dri and graphics/mesa-libs to 18.1.0

I have updated our development ree with mesa 18.1.0 release, you can find it here:
https://github.com/FreeBSDDesktop/freebsd-ports/tree/feature/mesa-18.1
I have also attached a patch against the FreeBSD svn ports tree.

Please give us two weeks to let this simmer and to test it out properly.

@Adam: The reason I haven't commented or done anything previously on this PR is that the Mesa release has still been in RC form, and not ready to put in the ports tree.  Instead I've tried to update other parts of the FreeBSD xorg stack.
Comment 11 Niclas Zeising freebsd_committer 2018-05-20 10:07:34 UTC
Created attachment 193555 [details]
Update graphics/mesa-dri and graphics/mesa-libs to 18.1.0

Updated patch.
Whitespace fixes and rolled in patch from pr223014
Comment 12 Jan Beich freebsd_committer 2018-05-20 14:44:35 UTC
@zeising, I'd appreciate if you don't bundle unrelated changes. Blob commits complicate backports (i.e., bug 223014 needs MFH) and regression tracking (e.g., bug 217585). In this sense, src/ folks have better commit hygiene.
Comment 13 Niclas Zeising freebsd_committer 2018-05-20 14:49:18 UTC
(In reply to Jan Beich from comment #12)

I'll separate out the changes once I commit, however I think it's better to leave the patch as-is for now, since both needs testing.
Comment 14 Jan Beich freebsd_committer 2018-05-29 16:41:03 UTC
Carlos or Kevin, can you check for regressions on FreeBSD < 11.2?
Comment 15 Carlos J. Puga Medina freebsd_committer 2018-05-29 18:32:20 UTC
Created attachment 193822 [details]
glxinfo-mesa-18.1.0.txt

(In reply to Jan Beich from comment #14)

Hi Jan,

It works as expected with the Sandy Bridge.

Tested on 10.4-RELEASE/amd64.
Comment 16 rkoberman 2018-05-30 07:38:03 UTC
(In reply to Jan Beich from comment #14)
Sorry, but I am having hardware issues on my Sandy Bridge system and won't be able to test until this afternoon (UTC -7). Will report ASAP. Currently running STABLE r334111 (AKA BETA2), so only slightly <11.2.
Comment 17 commit-hook freebsd_committer 2018-05-30 19:18:21 UTC
A commit references this bug:

Author: zeising
Date: Wed May 30 19:18:02 UTC 2018
New revision: 471152
URL: https://svnweb.freebsd.org/changeset/ports/471152

Log:
  graphics/mesa-libs, graphics/mesa-dri: Update to 18.1.0

  Update mesa ports to 18.1

  Changes:	https://www.mesa3d.org/relnotes/18.1.0.html

  PR:		227685
  Submitted by:	jbeich
  Tested by:	Greg V, Carlos J. Puga Medina

Changes:
  head/graphics/mesa-dri/Makefile.common
  head/graphics/mesa-dri/distinfo
  head/graphics/mesa-dri/files/patch-src_gallium_auxiliary_util_u__network.c
  head/graphics/mesa-dri/files/patch-src_gallium_drivers_freedreno_freedreno__screen.c
  head/graphics/mesa-dri/files/patch-src_util_os__time.c
Comment 18 Niclas Zeising freebsd_committer 2018-05-30 19:19:39 UTC
Committed, thanks!
Comment 19 commit-hook freebsd_committer 2018-06-16 00:44:20 UTC
A commit references this bug:

Author: jbeich
Date: Sat Jun 16 00:43:38 UTC 2018
New revision: 472506
URL: https://svnweb.freebsd.org/changeset/ports/472506

Log:
  graphics/mesa-{libs,dri}: update to 18.1.2

  Changes:	https://www.mesa3d.org/relnotes/18.1.2.html
  PR:		227685

Changes:
  head/graphics/mesa-dri/Makefile.common
  head/graphics/mesa-dri/Makefile.targets
  head/graphics/mesa-dri/distinfo