Bug 227689 - getrusage() still stops counting after a while
Summary: getrusage() still stops counting after a while
Status: Closed DUPLICATE of bug 76972
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 11.1-STABLE
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-04-22 10:04 UTC by ben
Modified: 2019-02-10 22:56 UTC (History)
5 users (show)

See Also:


Attachments
Reproducer (975 bytes, text/plain)
2018-04-22 10:04 UTC, ben
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description ben 2018-04-22 10:04:44 UTC
Created attachment 192723 [details]
Reproducer

This has been reported (and allegedly fixed) before, e.g. #78957, but it is still true.

After around 100 hours, getrusage() stops counting.

The attached demo stopped with output:

... [381082, 999593]T10.6742 1 [381093, 671972]T10.6724 0 [381104, 363990]T10.692 1 [381104, 363990]T0 0 [381104, 363990]T0 1 [381104, 363990]T0 1 [381104, 363990]T0 1 [381104, 363990]T0

% uname -a
FreeBSD bigcat 11.1-RELEASE-p4 FreeBSD 11.1-RELEASE-p4 #0: Tue Nov 14 06:12:40 UTC 2017     root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC  amd64
Comment 1 Konstantin Belousov freebsd_committer 2018-04-22 13:26:38 UTC
I am not aware of the fix committed.

You might try the patch from https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=76972
Comment 2 Conrad Meyer freebsd_committer 2019-02-10 22:56:58 UTC

*** This bug has been marked as a duplicate of bug 76972 ***