Bug 227743 - bxe cards require promisc for OSPF
Summary: bxe cards require promisc for OSPF
Status: Closed DUPLICATE of bug 213606
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 11.1-STABLE
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-net mailing list
URL: https://redmine.pfsense.org/issues/8324
Keywords:
Depends on:
Blocks:
 
Reported: 2018-04-24 13:47 UTC by Alexey
Modified: 2018-04-25 11:26 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey 2018-04-24 13:47:14 UTC
Hello.
The OSPF (FRR 4.0) does not want connect with neighbors until I set the network card promisc mode:

ifconfig bxe0 promisc

on this mode all working.

Other neighbors see this  neighbor and it is constantly in INIT mode.

Found a link to pfsense with a description of the problem: https://redmine.pfsense.org/issues/8324

FreeBSD virtualbox0.isp.kh.ua 11.2-PRERELEASE FreeBSD 11.2-PRERELEASE #0 r332927: Tue Apr 24 14:02:31 EEST 2018     pautina@virtualbox0:/usr/obj/usr/src/sys/VIRTUALBOX  amd64
Comment 1 Eugene Grosbein freebsd_committer 2018-04-25 11:26:14 UTC
This is known problem with bxe(4) driver that has broken incoming multicast processing. Closing this as duplicate of the PR 213606 that has more details.

Meantime, you may try to fix the driver yourself as driver author seems to be unresponsible or switch to another NIC.

*** This bug has been marked as a duplicate of bug 213606 ***