Bug 227792 - x11-wm/fluxbox: newly opened applications aren't managed by fluxbox after a monitor reconfiguration
Summary: x11-wm/fluxbox: newly opened applications aren't managed by fluxbox after a m...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Alan Somers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-04-26 16:00 UTC by Alan Somers
Modified: 2018-05-10 20:06 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (jgh)


Attachments
Apply upstream patch for PR 227792 (5.89 KB, patch)
2018-04-26 16:04 UTC, Alan Somers
asomers: maintainer-approval?
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alan Somers freebsd_committer 2018-04-26 16:00:14 UTC
After reconfiguring your monitors, some newly opened applications (for example, QTerminal) won't be managed by fluxbox (no borders, always on top, can't be moved or resized, and don't respect sloppy focus).  The bug was fixed in Fluxbox ages ago, but unfortunately there hasn't been a release since then.  Let's patch it locally.

System info:
TrueOS Edge (based on FreeBSD 12)
Fluxbox 1.3.7
Lumina Desktop Environment
QTerminal 0.8.0

Steps to reproduce:
1) Start Fluxbox
2) Open a QTerminal
3) Power off the monitor, or connect an external one
4) Wait 5 seconds
5) Power on the monitor, or remove the external one
6) Start a new QTerminal

The new QTerminal will be outside of fluxbox's control, as described.  Only restarting Fluxbox will fix the problem.
Comment 2 commit-hook freebsd_committer 2018-05-10 20:02:53 UTC
A commit references this bug:

Author: asomers
Date: Thu May 10 20:02:34 UTC 2018
New revision: 469574
URL: https://svnweb.freebsd.org/changeset/ports/469574

Log:
  x11-wm/fluxbox: x11-wm/fluxbox: apply upstream patch for multiple bugs

  Fixes upstream bugs 1058, 1102, 1111, and 1140.  Fluxbox hasn't made a
  release for 3 years, so we should stop waiting and patch our ports tree.

  https://github.com/fluxbox/fluxbox/commit/dcdde4d32c93d01df205bc06d7dfcbd356be031f
  https://sourceforge.net/p/fluxbox/bugs/1140/
  https://sourceforge.net/p/fluxbox/bugs/1111/
  https://sourceforge.net/p/fluxbox/bugs/1102/
  https://sourceforge.net/p/fluxbox/bugs/1058/

  PR:		227792
  Approved by:	maintainer timeout (jgh)

Changes:
  head/x11-wm/fluxbox/Makefile
  head/x11-wm/fluxbox/files/patch-src_FbRootWindow.cc
  head/x11-wm/fluxbox/files/patch-src_FbRootWindow.hh
  head/x11-wm/fluxbox/files/patch-src_FbWinFrame.cc
  head/x11-wm/fluxbox/files/patch-src_Screen.cc