Bug 227854 - archivers/urbackup-client: Update to 2.2.6. Add default config. Add log rotation
Summary: archivers/urbackup-client: Update to 2.2.6. Add default config. Add log rotation
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Kurt Jaeger
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-04-29 14:54 UTC by freebsd
Modified: 2018-08-09 02:44 UTC (History)
2 users (show)

See Also:
koobs: maintainer-feedback+


Attachments
add default config file and log rotation (via newsyslog) (4.88 KB, patch)
2018-04-29 14:54 UTC, freebsd
no flags Details | Diff
add default config file and log rotation (via newsyslog) v2 (4.92 KB, patch)
2018-04-29 18:29 UTC, freebsd
no flags Details | Diff
Update to 2.2.6; Add default config; Add log rotation (9.82 KB, patch)
2018-08-05 22:18 UTC, freebsd
freebsd: maintainer-approval+
Details | Diff
Update to 2.2.6; Add default config; Add log rotation (removes dos line endings) (10.06 KB, patch)
2018-08-09 00:59 UTC, freebsd
freebsd: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description freebsd 2018-04-29 14:54:36 UTC
Created attachment 192912 [details]
add default config file and log rotation (via newsyslog)

Revision:
 - Add a default config file (%%PREFIX%%/etc/urbackup/urbackupclient.conf)
 - Add log rotation (%%PREFIX%%/etc/newsyslog.conf.d/urbackupclient.conf)
Comment 1 freebsd 2018-04-29 18:29:57 UTC
Created attachment 192917 [details]
add default config file and log rotation (via newsyslog) v2

Minor update to prior .diff to specify PID file in log rotation config
Comment 2 freebsd 2018-08-05 22:18:49 UTC
Created attachment 195921 [details]
Update to 2.2.6; Add default config; Add log rotation

A new version 2.2.6 was released since this PR was originally opened. This patch updates to 2.2.6, and retains the prior improvements (default config and log rotation).
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2018-08-05 23:23:38 UTC
@Kirk Thank you for the patch. Can you please confirm that the changes pass QA (portlint, poudriere at least).

Also, don't forget to set the maintainer-approval flag to "+" on attachments for ports you are maintainer of. Attachment -> Details -> maintainer-approval [+]
Comment 4 freebsd 2018-08-05 23:45:25 UTC
(In reply to Kubilay Kocak from comment #3)

@Kubilay, the port builds without error using "poudriere testport", and portlint produces some warnings* but no errors. 

I've set the maintainer-approval flag (thanks for letting me know I should do that).

[*] The warnings suggest a NLS knob to due to use of gettext, and indicate that a couple of the patches contain ^M characters (based on those characters existing in the upstream sources).
Comment 5 Kubilay Kocak freebsd_committer freebsd_triage 2018-08-06 00:59:36 UTC
(In reply to freebsd from comment #4)

Thanks Kirk

The only other thing I would suggest (to assist QA and understanding the changeset), it to add comments in each files/patch-* header to reference what the patch is for (what the issue is), and includes links to upstream bug reports, pull requests and/or commits, where available, to keep track.
Comment 6 Kurt Jaeger freebsd_committer 2018-08-07 16:41:07 UTC
Some of the new files/patch-client* files have DOS lineendings, and svn rejects them:

svn: E200009: File '/home/pi/m/archivers/urbackup-client/files/patch-client_ConfigPath.cpp' has inconsistent newlines

Can you try to get this consistent ?
Comment 7 freebsd 2018-08-09 00:59:48 UTC
Created attachment 196020 [details]
Update to 2.2.6; Add default config; Add log rotation (removes dos line endings)

New diff that addresses the dos line ending issue (I've added dos2unix to the uses line in the Makefile, and regenerated the patches). I've also added comments to the patches indicating their purpose, as suggested by Kubilay.

No errors from portlint, and builds under poudriere.

Overall changelog (vs committed port):
* Update to 2.2.6
* Add a default configuration file
* Add log rotation via newsyslog
Comment 8 Kurt Jaeger freebsd_committer 2018-08-09 02:43:50 UTC
Committed, thanks. With the next update, please try to silence portlint for the patch format.
Comment 9 commit-hook freebsd_committer 2018-08-09 02:44:37 UTC
A commit references this bug:

Author: pi
Date: Thu Aug  9 02:43:47 UTC 2018
New revision: 476717
URL: https://svnweb.freebsd.org/changeset/ports/476717

Log:
  archivers/urbackup-client: update 2.2.5 -> 2.2.6

  - Add a default configuration file
  - Add log rotation via newsyslog

  PR:		227854
  Submitted by:	freebsd@coombscloud.com (maintainer)
  Reviewed by:	koobs
  Relnotes:	https://www.urbackup.org/client_changelog.html

Changes:
  head/archivers/urbackup-client/Makefile
  head/archivers/urbackup-client/distinfo
  head/archivers/urbackup-client/files/patch-client_ConfigPath.cpp
  head/archivers/urbackup-client/files/patch-client_stringtools.cpp
  head/archivers/urbackup-client/files/patch-client_stringtools.h
  head/archivers/urbackup-client/files/pkg-message.in
  head/archivers/urbackup-client/files/urbackup_client.in
  head/archivers/urbackup-client/files/urbackupclient.conf-newsyslog
  head/archivers/urbackup-client/files/urbackupclient.conf.sample-daemon.in
  head/archivers/urbackup-client/pkg-plist