Bug 227857 - science/hdf5-18: H5PaccProp.h should not be limited to Fortran builds
Summary: science/hdf5-18: H5PaccProp.h should not be limited to Fortran builds
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Thierry Thomas
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-04-29 18:13 UTC by Jason W. Bacon
Modified: 2018-05-07 19:21 UTC (History)
0 users

See Also:
thierry: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jason W. Bacon freebsd_committer 2018-04-29 18:13:39 UTC
Discovered this while poudiere testing blasr_libcpp:

/usr/ports/science/hdf5-18/pkg-plist:%%FORTRAN%%include/hdf5-18/H5LaccProp.h
/usr/ports/science/hdf5/pkg-plist:include/H5LaccProp.h

/usr/local/include/hdf5-18/H5Cpp.h:#include "H5LaccProp.h"

If hdf5 is installed in addition to hdf5-18, the problem is masked because the hdf5-18 headers pick up /usr/local/include/H5LaccProp.h.

Poudriere testport exposes it by starting the build with no packages preinstalled.
Comment 1 Thierry Thomas freebsd_committer 2018-05-07 19:21:13 UTC
Thanks for the report!
Comment 2 commit-hook freebsd_committer 2018-05-07 19:21:41 UTC
A commit references this bug:

Author: thierry
Date: Mon May  7 19:21:09 UTC 2018
New revision: 469323
URL: https://svnweb.freebsd.org/changeset/ports/469323

Log:
  Fix plist whith FORTRAN option.

  PR:		227857
  Submitted by:	jwb

Changes:
  head/science/hdf5-18/Makefile
  head/science/hdf5-18/pkg-plist