Bug 227908 - net/wireshark 2.6.0 doesn't build with kerberos in base
Summary: net/wireshark 2.6.0 doesn't build with kerberos in base
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Joe Marcus Clarke
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-01 19:39 UTC by Marco Beishuizen
Modified: 2018-05-02 13:38 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (marcus)


Attachments
net/wireshark patch to make wireshark build with kerberos in base (646 bytes, patch)
2018-05-01 22:08 UTC, Marco Beishuizen
mbeis: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Marco Beishuizen 2018-05-01 19:39:40 UTC
Installing net/wireshark 2.6.0 results in a configure error:

...
checking for netinet/in.h... (cached) yes
checking for arpa/inet.h... (cached) yes
checking ifaddrs.h usability... yes
checking ifaddrs.h presence... yes
checking for ifaddrs.h... yes
checking whether to use Kerberos library... yes
checking for krb5-config... /usr/bin/krb5-config
configure: error: Kerberos library requires -lcrypto, so you must specify --with-krb5-crypto-openssl
===>  Script "configure" failed unexpectedly.
Please report the problem to marcus@FreeBSD.org [maintainer] and attach the
"/usr/ports/net/wireshark/work/wireshark-2.6.0/config.log" including the
output of the failure of your make command. Also, it might be a good idea to
provide an overview of all packages installed on your system (e.g. a
/usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/net/wireshark
*** Error code 1
...

In the options, the "Kerberos support via base system" is checked (is the default). My uname -a:
FreeBSD yokozuna 11.1-STABLE FreeBSD 11.1-STABLE #0 r328478: Sat Jan 27 22:31:28 CET 2018     root@yokozuna:/usr/obj/usr/src/sys/YOKOZUNA  amd64
Comment 1 VVD 2018-05-01 21:02:46 UTC
Workaround:
> --- Makefile.orig
> +++ Makefile
> @@ -103,7 +103,7 @@
>                         libgcrypt.so:security/libgcrypt
>  
>  KRB_NONE_CONFIGURE_ON= --without-krb5
> -KRB_NONE_CONFIGURE_OFF=        --with-krb5
> +KRB_NONE_CONFIGURE_OFF=        --with-krb5 --with-krb5-crypto-openssl
>  KRB_NONE_CONFIGURE_ENV_OFF=    KRB5_CONFIG=${KRB5CONFIG}
>  
>  GTK2_CONFIGURE_ON=     --with-gtk=2 --with-qt=no
Comment 2 Marco Beishuizen 2018-05-01 22:08:31 UTC
Created attachment 192983 [details]
net/wireshark patch to make wireshark build with kerberos in base
Comment 3 O. Hartmann 2018-05-02 05:21:55 UTC
Since the build with kerberos in base is a default option, I'm wondering how this could pass any test on CURRENT.
Comment 4 O. Hartmann 2018-05-02 05:31:21 UTC
The patch works for me. At least, I can compile and install the port on recent CURRENT via the traditional way and poudriere.
Comment 5 commit-hook freebsd_committer 2018-05-02 13:37:49 UTC
A commit references this bug:

Author: marcus
Date: Wed May  2 13:37:39 UTC 2018
New revision: 468838
URL: https://svnweb.freebsd.org/changeset/ports/468838

Log:
  Fix build with base krb5.

  Add an additional CONFIGURE_ARG to allow wireshark to build with base Kerberos.

  PR:		227908
  Submitted by:	mbeis

Changes:
  head/net/wireshark/Makefile
Comment 6 Joe Marcus Clarke freebsd_committer 2018-05-02 13:38:31 UTC
Committed, thanks!