Bug 227947 - devel/py-jedi: needs to depend on textproc/py-parso
Summary: devel/py-jedi: needs to depend on textproc/py-parso
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Steven Kreuzer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-03 10:12 UTC by hliebel
Modified: 2018-05-03 13:43 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hliebel 2018-05-03 10:12:48 UTC
py-jedi needs py-parso to work. Looking at the changelog the parso function was split off in v0.11.0 of jedi. Trying to use jedi without parso installed causes an error.
Comment 1 commit-hook freebsd_committer 2018-05-03 13:42:55 UTC
A commit references this bug:

Author: skreuzer
Date: Thu May  3 13:42:34 UTC 2018
New revision: 468928
URL: https://svnweb.freebsd.org/changeset/ports/468928

Log:
  Update to version 0.12.0
  Add textproc/py-parso as a dependency

  PR:		227947
  Reported by:	hliebel@gmail.com

Changes:
  head/devel/py-jedi/Makefile
  head/devel/py-jedi/distinfo
Comment 2 Steven Kreuzer freebsd_committer 2018-05-03 13:43:56 UTC
Thanks for the report! I added textproc/py-parso as a dependency and also updated the port to v0.12.0