Bug 228039 - ports-mgmt/pkg segfaults when it should remove a locked package
Summary: ports-mgmt/pkg segfaults when it should remove a locked package
Status: Closed Works As Intended
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Walter Schwarzenfeld
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-07 10:59 UTC by Niels Kobschätzki
Modified: 2019-09-05 04:05 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Niels Kobschätzki 2018-05-07 10:59:37 UTC
I had dovecot in version 2.2.35 installed and an upgrade would have upgraded it to 2.3.x. So I locked dovecot. Then I built dovecot22 on my poudriere and did a "pkg install dovecot22". And pkg segfaulted.
After I unlocked dovecot, I could install dovecot22 and dovecot got removed.
Comment 1 Walter Schwarzenfeld freebsd_triage 2019-09-04 18:10:11 UTC
I have never seen this error. Is this still relevant?
Comment 2 Niels Kobschätzki 2019-09-05 04:01:36 UTC
I am not sure. I have not seen it yet so far but I also know the workaround.
Since this bug report is already more than a year old, I can only imagine that the problem was that "dovecot" was locked, and dovecot22 was more or less dovecot but a renamed package and that this triggered the problem. I have currently no idea how to trigger this behavior. A year ago I might have been able to but now, I don't.
Comment 3 Walter Schwarzenfeld freebsd_triage 2019-09-05 04:05:10 UTC
Thanks for answer. I close for the moment here. Please, reopen if the problem appears again.