Bug 228058 - ports-mgmt/portlint: Complains "Choose another PORTVERSION or bump PORTEPOCH." when the DISTVERSION is actually increading
Summary: ports-mgmt/portlint: Complains "Choose another PORTVERSION or bump PORTEPOCH....
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Joe Marcus Clarke
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-08 04:32 UTC by Yuri Victorovich
Modified: 2018-05-08 13:05 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (marcus)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yuri Victorovich freebsd_committer 2018-05-08 04:32:24 UTC
The problem was observed in textproc/dikt.

Before r469254 this port had
PORTVERSION=    2l3
When in this condition PORTVERSION was changed to
DISTVERSION=    2s1
portlint complained:
> $ portlint -C
> FATAL: Makefile: dikt-2.s1 < dikt-2l3_2. Choose another PORTVERSION or bump PORTEPOCH.
> 1 fatal error and 0 warnings found. 

This is wrong because 2l3 < 2s1.

There are very few versions in this format, but it looks like portlint doesn't handle them correctly.
Comment 1 Mathieu Arnold freebsd_committer 2018-05-08 13:05:29 UTC
I'm closing this as not a bug.
The bug was in the port using DISTVERSION to begin with.