Bug 228106 - www/otrs install missed DBUpdateTo6 scripts and fix an issue with Sisimai module
Summary: www/otrs install missed DBUpdateTo6 scripts and fix an issue with Sisimai module
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Kurt Jaeger
URL:
Keywords:
Depends on: 228201
Blocks: 227924
  Show dependency treegraph
 
Reported: 2018-05-10 01:21 UTC by m.tsatsenko
Modified: 2018-05-15 13:38 UTC (History)
1 user (show)

See Also:


Attachments
the patch (233.14 KB, text/plain)
2018-05-10 01:21 UTC, m.tsatsenko
m.tsatsenko: maintainer-approval-
Details
updated patch (6.33 KB, patch)
2018-05-15 00:37 UTC, m.tsatsenko
m.tsatsenko: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description m.tsatsenko 2018-05-10 01:21:55 UTC
Created attachment 193224 [details]
the patch

- Install DBUpdateTo6 scripts required to perform an update to 6.x.x
- Add a dirty hack to deal with Sisimai module (to be removed once we have it in the ports tree)

See #227924 for details

Submitted by: Felix J. Ogris <fjo at ogris dot de> (with minor changes)

QA:
portlint no errors
poudriere 111amd64 no errors
Comment 1 Kurt Jaeger freebsd_committer 2018-05-12 16:53:38 UTC
I provided a port for Sisimai -- can you test if that port satisfies the requirements of this OTRS update ?
Comment 2 m.tsatsenko 2018-05-14 09:03:36 UTC
Hello,
Thanks for your work!
The port you  have created is fine from otrs perspective.
I will follow up with modified patch soon. (going to fix a few more minor issues while here)
Comment 3 m.tsatsenko 2018-05-15 00:37:16 UTC
Created attachment 193406 [details]
updated patch

- Add missing dependencies
- Attempt to run otrs.SetPermissions.pl script on install. It is going to work if there is an existing otrs user from the previous installation. Users installing the port for the first time should run it manually as stated in pkg-message.
- Install DBUpdateTo6 scripts
Comment 4 m.tsatsenko 2018-05-15 00:38:28 UTC
QA
poudriere 111amd64 no errors
portlint no errors
Comment 5 Kurt Jaeger freebsd_committer 2018-05-15 13:07:31 UTC
testbuilds@work
Comment 6 commit-hook freebsd_committer 2018-05-15 13:37:16 UTC
A commit references this bug:

Author: pi
Date: Tue May 15 13:37:06 UTC 2018
New revision: 470015
URL: https://svnweb.freebsd.org/changeset/ports/470015

Log:
  www/otrs: add missing dependencies, and missing DBUpdateTo6 scripts

  - Add missing dependencies
  - Attempt to run otrs.SetPermissions.pl script on install. It is going
    to work if there is an existing otrs user from the previous
    installation. Users installing the port for the first time should
    run it manually as stated in pkg-message.
  - Install DBUpdateTo6 scripts

  PR:		227924, 228106
  Reported by:	jonaspalm@posteo.de
  Submitted by:	m.tsatsenko@gmail.com (maintainer), Felix J. Ogris <fjo@ogris.de>

Changes:
  head/www/otrs/Makefile
  head/www/otrs/files/pkg-message.in
  head/www/otrs/pkg-plist
Comment 7 Kurt Jaeger freebsd_committer 2018-05-15 13:38:46 UTC
Committed, thanks!