Bug 228107 - graphics/leptonica: Excessive dependencies
Summary: graphics/leptonica: Excessive dependencies
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-10 08:29 UTC by Niclas
Modified: 2019-08-28 15:08 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (hiroto.kagotani)


Attachments
Cleanup/Modernize; Remove un-needed dep (2.37 KB, patch)
2018-09-02 06:08 UTC, Nathan
ndowens04: maintainer-approval? (hiroto.kagotani)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Niclas 2018-05-10 08:29:26 UTC
Currently graphics/leptonica builds math/gnuplot without an option to turn it off even though it isn't listed as a dependency.

math/gnuplot has switched to being a full X11 graphical application and made math/gnuplot-lite if only the cmd utility is needed.

This makes graphics/leptonica build lots of X11 and GTK+2 dependencies that shouldn't be needed.
Comment 1 Nathan 2018-09-02 06:08:40 UTC
Created attachment 196780 [details]
Cleanup/Modernize; Remove un-needed dep

graphics/leptonica:
* Changed to OPTIONS
  -- Modernize/cleanup
* Add test target
  -- Remove old-style
* Remove gnuplot dep
  -- Was not needed for tests
* Add/fix License block
  -- While here and to correct issue
Comment 2 Walter Schwarzenfeld freebsd_triage 2019-08-13 20:17:11 UTC
Maintainer feedback, please!