Bug 228150 - www/sogo3 Build's but does not start after upgrade libressl-2.6.x -> libressl-2.7.3
Summary: www/sogo3 Build's but does not start after upgrade libressl-2.6.x -> libressl...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Some People
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords:
Depends on:
Blocks: 226843
  Show dependency treegraph
 
Reported: 2018-05-11 09:52 UTC by gspu
Modified: 2019-01-24 13:04 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (euan)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gspu 2018-05-11 09:52:06 UTC
# service sogod restart
sogod not running? (check /var/run/sogo/sogo.pid).
Starting sogod.
Shared object "libssl.so.44" not found, required by "libNGStreams.so.4.9"
/usr/local/etc/rc.d/sogod: WARNING: failed to start sogod
Comment 1 Bernard Spil freebsd_committer 2018-05-21 10:30:34 UTC
Looks like your environment is broken. libssl is version 45 in the LibreSSL ports. Have you recompiled/-installed all ports depending on LibreSSL after updating? (see UPDATING).
Comment 2 gspu 2019-01-15 16:29:39 UTC
Yes i recompiled all packages (portmaster -adf)
Comment 3 gspu 2019-01-24 13:04:10 UTC
Ok, i rebuild everything but still same problem, but when i removed Sogo manually (pkg remove -f) and reinstalled it (with portmaster), everything works fine. I know don't mix port-usage and pkg...but sometimes it works :-)

Have a nice Day and thanks!