Bug 228241 - games/ninix-aya: Update to 5.0.6
Summary: games/ninix-aya: Update to 5.0.6
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Kurt Jaeger
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-14 09:28 UTC by Yasuhiro KIMURA
Modified: 2018-07-09 05:23 UTC (History)
4 users (show)

See Also:


Attachments
patch file (381 bytes, patch)
2018-05-14 09:28 UTC, Yasuhiro KIMURA
no flags Details | Diff
updated patch file (1.07 KB, patch)
2018-05-15 18:25 UTC, Yasuhiro KIMURA
no flags Details | Diff
what_I_changed-svn-diff (8.16 KB, patch)
2018-06-18 12:31 UTC, Walter Schwarzenfeld
no flags Details | Diff
updated patch file (9.57 KB, patch)
2018-06-29 11:08 UTC, Yasuhiro KIMURA
no flags Details | Diff
Screen shot of display (76.01 KB, image/png)
2018-06-29 11:19 UTC, Yasuhiro KIMURA
no flags Details
updated patch file (9.57 KB, patch)
2018-07-08 09:03 UTC, Yasuhiro KIMURA
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yasuhiro KIMURA 2018-05-14 09:28:57 UTC
Created attachment 193383 [details]
patch file

Mark BROKEN because distfile is  unfetchable.
Comment 1 Kirill Ponomarev freebsd_committer 2018-05-14 16:58:46 UTC
=> Attempting to fetch http://distcache.FreeBSD.org/ports-distfiles/ninix-aya-4.4.tgz                                        
ninix-aya-4.4.tgz                             100% of  327 kB 1129 kBps 00m00s                                               
===> Fetching all distfiles required by ninix-aya-4.4_6 for building                                                         
=> SHA256 Checksum OK for ninix-aya-4.4.tgz.

So I could fetch tarball
Comment 2 Yasuhiro KIMURA 2018-05-14 17:25:14 UTC
(In reply to Kirill Ponomarev from comment #1)

Is it OK that distfile is unfetchable from MASTER_SITES and fetchable only from distcache.FreeBSD.org?
Comment 3 Mark Linimon freebsd_committer freebsd_triage 2018-05-15 00:21:31 UTC
(In reply to Yasuhiro KIMURA from comment #2)

My understanding is that FreeBSD strongly prefers not to be the only 'upstream' site.  If the upstream no longer exists, the preferred course of action is for someone to pick up maintainership and host the files on github or some similar site.
Comment 4 Yasuhiro KIMURA 2018-05-15 18:25:12 UTC
Created attachment 193435 [details]
updated patch file

(In reply to Mark Linimon from comment #3)

Thank you for reply. I found debian has same source archive with different name and updated patch to switch MASTER_SITE to DEBIAN_POOL. So please commit attached patch instead of original one.
Comment 5 Kurt Jaeger freebsd_committer 2018-06-17 19:33:04 UTC
There is a real upstream site at Sourceforge (SF). But it only has newer versions, not the old distfile. And the newer versions need fixes to build.

As far as I understand the policy says to not accept other projects
distcache-like infrastructure as MASTER_SITES. DEBIAN_POOL
is very similar to the FreeBSD distcache.

See 

https://lists.freebsd.org/pipermail/freebsd-ports/2018-June/113652.html

for more details on this topic.
Comment 6 Walter Schwarzenfeld freebsd_triage 2018-06-17 19:55:15 UTC
Maybe, this one:

http://ftp.vim.org/os/Linux/distr/deepin/pool/main/n/ninix-aya/
Comment 7 Walter Schwarzenfeld freebsd_triage 2018-06-17 20:32:18 UTC
Sorry, no does not work.
Comment 8 Walter Schwarzenfeld freebsd_triage 2018-06-17 20:43:10 UTC
The MASTER_SITE is ok. The version is too old, needs updated.
If I change to:

PORTVERSION=    5.0.5
CATEGORIES=     games
MASTER_SITES=   OSDN/${PORTNAME}/68886

It fetches fine.
Comment 9 Kurt Jaeger freebsd_committer 2018-06-17 20:59:12 UTC
Well, does it build then ?
Comment 10 Walter Schwarzenfeld freebsd_triage 2018-06-17 21:04:30 UTC
Kurt, all description are in japanese (I don't know what it needed). 
It bzukds and installs, but if I try to start it states:

exec: @ruby: not found
Comment 11 Walter Schwarzenfeld freebsd_triage 2018-06-17 21:06:12 UTC
Further option DOC not work (no docs in the distfile).
Comment 12 Walter Schwarzenfeld freebsd_triage 2018-06-18 12:30:26 UTC
Makes no sense for me to try it, I know too less about ruby.
still got:
exec: @ruby: not found

If I remove "@" it tries to start, but:
/usr/local/lib/ruby/gems/2.4/gems/gobject-introspection-3.2.5/lib/gobject-introspection/loader.rb:317:in `invoke'
/usr/local/lib/ruby/gems/2.4/gems/gobject-introspection-3.2.5/lib/gobject-introspection/loader.rb:317:in `block (2 levels) in load_constructor_infos'
/usr/local/lib/ruby/gems/2.4/gems/gobject-introspection-3.2.5/lib/gobject-introspection/loader.rb:328:in `block in load_constructor_infos'
/usr/local/libexec/ninix/ninix/prefs.rb:333:in `new'
/usr/local/libexec/ninix/ninix/prefs.rb:333:in `make_page_surface_n_balloon'
/usr/local/libexec/ninix/ninix/prefs.rb:135:in `initialize'
/usr/local/libexec/ninix/ninix_main.rb:339:in `new'
/usr/local/libexec/ninix/ninix_main.rb:339:in `initialize'
/usr/local/libexec/ninix/ninix_main.rb:127:in `new'
/usr/local/libexec/ninix/ninix_main.rb:127:in `main'
/usr/local/libexec/ninix/ninix_main.rb:1701:in `<main>'
Comment 13 Walter Schwarzenfeld freebsd_triage 2018-06-18 12:31:31 UTC
Created attachment 194356 [details]
what_I_changed-svn-diff

This is what I changed in the moment.
Comment 14 Yasuhiro KIMURA 2018-06-29 11:08:50 UTC
Created attachment 194722 [details]
updated patch file

With attached patch ninix starts and client window appears on X
display. But following runtime error messages are displayed.

----------------------------------------------------------------------
I, [2018-06-29T15:36:27.239427 #54453]  INFO -- : loading...
E, [2018-06-29T15:36:27.244415 #54453] ERROR -- : Uncaught exception (ArgumentError)
/usr/local/lib/ruby/gems/2.4/gems/gobject-introspection-3.2.5/lib/gobject-introspection/loader.rb:317:in `invoke'
/usr/local/lib/ruby/gems/2.4/gems/gobject-introspection-3.2.5/lib/gobject-introspection/loader.rb:317:in `block (2 levels) in load_constructor_infos'
/usr/local/lib/ruby/gems/2.4/gems/gobject-introspection-3.2.5/lib/gobject-introspection/loader.rb:328:in `block in load_constructor_infos'
/usr/local/lib/ninix/ninix/prefs.rb:333:in `new'
/usr/local/lib/ninix/ninix/prefs.rb:333:in `make_page_surface_n_balloon'
/usr/local/lib/ninix/ninix/prefs.rb:135:in `initialize'
/usr/local/lib/ninix/ninix_main.rb:339:in `new'
/usr/local/lib/ninix/ninix_main.rb:339:in `initialize'
/usr/local/lib/ninix/ninix_main.rb:127:in `new'
/usr/local/lib/ninix/ninix_main.rb:127:in `main'
/usr/local/lib/ninix/ninix_main.rb:1701:in `<main>'
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.
----------------------------------------------------------------------

I'm going to ask advice in the forum of ninix-aya.
Comment 15 Yasuhiro KIMURA 2018-06-29 11:19:43 UTC
Created attachment 194723 [details]
Screen shot of display

Attached PNG image is screen shot of display.
Comment 16 Yasuhiro KIMURA 2018-07-05 18:42:02 UTC
(In reply to Yasuhiro KIMURA from comment #14)

> I'm going to ask advice in the forum of ninix-aya.

Submitted.

https://osdn.net/projects/ninix-aya/forums/2193/39736/

Keep in mind Japanese is used in this forum.
Comment 17 Yasuhiro KIMURA 2018-07-08 09:03:17 UTC
Created attachment 194946 [details]
updated patch file

New version 5.0.6 is released.
I confirmed run time error reported in previous comments is fixed.
I also confirmed build succeeds with poudriere and 11.2-RELEASE amd64 jail.
So please commit attached patch instead of previous ones.
Comment 18 Kurt Jaeger freebsd_committer 2018-07-08 09:35:30 UTC
testbuilds@work
Comment 19 Kurt Jaeger freebsd_committer 2018-07-08 09:38:28 UTC
Any chance for a changelog since 4.x something ? A link to it would be fine, even if it's limited to a japanese changelog -- as the port is mainly used by japanese users.
Comment 20 Yasuhiro KIMURA 2018-07-08 11:39:31 UTC
(In reply to Kurt Jaeger from comment #19)

I compared following 2 ChangeLogs:

* ChangeLog from HEAD of current developement repository.
  (https://osdn.net/projects/ninix-aya/scm/git/ruby-gtk3/blobs/master/ChangeLog)

* ChangeLog included in source archive of version 4.4.
  (http://http.debian.net/debian/pool/main/n/ninix-aya/ninix-aya_4.4.orig.tar.gz)

At first I expected simply diff-ing provides changelog from 4.4 to 5.0.6. But unfortunately it was not so simple because

* After 4.3.9 is release developement was split into 2 repositories.
  (a) Repository for active developement and reaches 5.0.6
  (b) Repository for maintaining 4.x and released 4.4.
* Some new features are backported from (a) to (b) before 4.4 is released.
* And update of ChangLog in (b) is not simple copy-and-paste from ChngeLog in (a).

So It is difficult to create changelog from 4.4 to 5.0.6 by simply comparing above ChangeLogs.
Comment 21 Kurt Jaeger freebsd_committer 2018-07-09 05:22:17 UTC
Committed, thanks!
Comment 22 commit-hook freebsd_committer 2018-07-09 05:23:01 UTC
A commit references this bug:

Author: pi
Date: Mon Jul  9 05:22:14 UTC 2018
New revision: 474224
URL: https://svnweb.freebsd.org/changeset/ports/474224

Log:
  games/ninix-aya: update 4.4 -> 5.0.6

  PR:		228241
  Submitted by:	Yasuhiro KIMURA <yasu@utahime.org>
  Reviewed by:	krion, linimon, w.schwarzenfeld@utanet.at
  Relnotes:	https://osdn.net/projects/ninix-aya/scm/git/ruby-gtk3/blobs/master/ChangeLog

Changes:
  head/games/ninix-aya/Makefile
  head/games/ninix-aya/distinfo
  head/games/ninix-aya/files/
  head/games/ninix-aya/files/patch-Makefile
  head/games/ninix-aya/pkg-plist