Bug 228358 - graphics/inkscape C++ issue, but fixed upstream
Summary: graphics/inkscape C++ issue, but fixed upstream
Status: Closed DUPLICATE of bug 194760
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-gnome (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-19 07:00 UTC by Leon Dietrich
Modified: 2018-10-28 10:59 UTC (History)
0 users

See Also:


Attachments
The build log (37.99 KB, application/x-xz)
2018-05-19 07:00 UTC, Leon Dietrich
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Leon Dietrich 2018-05-19 07:00:12 UTC
Created attachment 193527 [details]
The build log

Inkscape fails to build from ports due to bad C++ code but succeeds to build from Git. Please review the attached build log for further details.
Comment 1 Jan Beich freebsd_committer 2018-10-28 10:59:33 UTC
-fopenmp and the following error suggests you've enabled OPENMP in graphics/ImageMagick

lib/libinkscape_base.so: undefined reference to `Magick::Blob::base64()'
lib/libinkscape_base.so: undefined reference to `Magick::Blob::base64(std::__1::basic_string<char, std::__1::char_traits<char>, std::__1::allocator<char> >)'
lib/libinkscape_base.so: undefined reference to `Magick::Image::magick() const'
lib/libinkscape_base.so: undefined reference to `Magick::Image::read(std::__1::basic_string<char, std::__1::char_traits<char>, std::__1::allocator<char> > const&)'
c++: error: linker command failed with exit code 1 (use -v to see invocation)

*** This bug has been marked as a duplicate of bug 194760 ***