Bug 228408 - sysutils/k3b: Missing multiple run dependencies, issuing invalid cdrecord command
Summary: sysutils/k3b: Missing multiple run dependencies, issuing invalid cdrecord com...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: kde
URL:
Keywords:
: 231002 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-05-21 23:21 UTC by Jason W. Bacon
Modified: 2019-04-16 06:59 UTC (History)
4 users (show)

See Also:
tcberner: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jason W. Bacon freebsd_committer 2018-05-21 23:21:42 UTC
Missing run dependencies:

sysutils/cdrdao devel/libburn sysutils/dvd+rw-tools

These might be installed by the kde metaports, but they turn up missing on a Lumina desktop system.

The following occurs when trying to erase a cdrw.  Same issue on two machines.

Devices
-----------------------
MATSHITA DVD/CDRW UJDA775 CB03 (/dev/cd0, CD-R, CD-RW, CD-ROM, DVD-ROM) [DVD-ROM, CD-ROM, CD-R, CD-RW] [SAO, TAO, RAW, SAO/R96P, SAO/R96R, RAW/R96R] [%7]

System
-----------------------
K3b Version: 18.4.1
KDE Version: 5.45.0
Qt Version:  5.10.1
Kernel:      11.1-RELEASE-p10

Used versions
-----------------------
cdrecord: 3.1

cdrecord
-----------------------
scsidev: '/dev/cd0'
devname: '/dev/cd0'
scsibus: -2 target: -2 lun: -2
cdrecord: Invalid argument. Open by 'devname' not supported on this OS. Cannot open or use SCSI driver.
cdrecord: For possible targets try 'cdrecord -scanbus'.
cdrecord: For possible transport specifiers try 'cdrecord dev=help'.
Cdrecord-ProDVD-ProBD-Clone 3.01 (amd64-unknown-freebsd11.0) Copyright (C) 1995-2015 Joerg Schilling
TOC Type: 1 = CD-ROM

cdrecord command:
-----------------------
/usr/local/bin/cdrecord -v gracetime=2 dev=/dev/cd0 speed=10 -tao driveropts=burnfree blank=fast

FreeBSD manatee.acadix  bacon ~ 1002: cdrecord -scanbus
Cdrecord-ProDVD-ProBD-Clone 3.01 (amd64-unknown-freebsd11.0) Copyright (C) 1995-2015 Joerg Schilling
Using libscg version 'schily-0.9'.
scsibus0:
	0,0,0	  0) 'MATSHITA' 'DVD/CDRW UJDA775' 'CB03' Removable CD-ROM
	0,1,0	  1) *
	0,2,0	  2) *
	0,3,0	  3) *
	0,4,0	  4) *
	0,5,0	  5) *
	0,6,0	  6) *
	0,7,0	  7) *
scsibus1:
	1,0,0	100) '' '' '' NON CCS Disk
	1,1,0	101) *
	1,2,0	102) *
	1,3,0	103) *
	1,4,0	104) *
	1,5,0	105) *
	1,6,0	106) *
	1,7,0	107) *
Comment 1 Jason W. Bacon freebsd_committer 2018-05-21 23:47:11 UTC
Also pkg-message refers to hw.ata.atapi_dma, which does not exist on my 11.1 systems, but the drive is recognized and k3b can identify the disc in it.

FreeBSD manatee.acadix  bacon ~ 1014: sysctl hw.ata
hw.ata.ata_dma_check_80pin: 1
FreeBSD manatee.acadix  bacon ~ 1015: 
cd0 at ata0 bus 0 scbus0 target 0 lun 0
cd0: <MATSHITA DVD/CDRW UJDA775 CB03> Removable CD-ROM SCSI device
cd0: 33.300MB/s transfers (UDMA2, ATAPI 12bytes, PIO 65534bytes)
cd0: Attempt to query device size failed: NOT READY, Medium not present - tray closed
Comment 2 commit-hook freebsd_committer 2018-05-22 05:24:44 UTC
A commit references this bug:

Author: tcberner
Date: Tue May 22 05:24:38 UTC 2018
New revision: 470595
URL: https://svnweb.freebsd.org/changeset/ports/470595

Log:
  sysutils/k3b: Add some more bunring dependencies

  PR:		228408

Changes:
  head/sysutils/k3b/Makefile
Comment 3 commit-hook freebsd_committer 2018-06-06 17:55:13 UTC
A commit references this bug:

Author: adridg
Date: Wed Jun  6 17:55:09 UTC 2018
New revision: 471862
URL: https://svnweb.freebsd.org/changeset/ports/471862

Log:
  Fix pkg-message of sysutils/k3b

   - Remove sentence that suggests that FreeBSD 7.x is still a going concern
   - Remove reference to sysctl that doesn't exist in any supported version

  This does not fix the problem that k3b doesn't *work*, though. Since
  cdrecord no longer accepts dev=/dev/cd0 , k3b will consistently fail to
  blank a CD, as reported in the linked PR.

  PR:		228408
  Submitted by:	jwb

Changes:
  head/sysutils/k3b/pkg-message
Comment 4 Adriaan de Groot freebsd_committer 2018-09-06 21:15:52 UTC
Another problem with the command-lines being used, reported in PR 231002 by Thierry Thomas:

===
When running k3b-18.08.0 to create a DVD of data, it fails with the following message:

Devices
-----------------------
TSSTcorp CDDVDW SH-216BB FT01 (/dev/cd0, CD-R, CD-RW, CD-ROM, DVD-ROM, DVD-R, DVD-RW, DVD-R DL, DVD+R, DVD+RW, DVD+R DL) [DVD-ROM, DVD-R séquentiel, DVD-R double couche séquentiel, DVD+R double couche avec saut, DVD-RAM, DVD-RW à ré-inscription limitée, DVD-RW séquentiel, DVD+RW, DVD+R, DVD+R double couche, CD-ROM, CD-R, CD-RW] [SAO, TAO, RAW, SAO/R96P, SAO/R96R, RAW/R16, RAW/R96P, RAW/R96R, Ré-inscription restreinte, Saut de couche] [%7]

System
-----------------------
K3b Version: 18.4.3
KDE Version: 5.47.0
Qt Version:  5.10.1
Kernel:      11.2-STABLE

Used versions
-----------------------
mkisofs: 3.1-fix-20151126

mkisofs
-----------------------
1959155
mkisofs: Warning: Cannot add inode hints with -no-cache-inodes.

mkisofs calculate size command:
-----------------------
/usr/local/bin/mkisofs -gui -graft-points -print-size -quiet -volid S180829 -volset  -appid K3B THE CD KREATOR (C) 1998-2017 SEBASTIAN TRUEG, MICHAL MALEK AND LESLIE ZHAI -publisher  -preparer  -sysid FREEBSD -volset-size 1 -volset-seqno 1 -sort /tmp/k3b.zMhABM -rational-rock -hide-list /tmp/k3b.NZLgIL -joliet -joliet-long -hide-joliet-list /tmp/k3b.UKKqhF -no-cache-inodes -udf -full-iso9660-filenames -iso-level 3 -path-list /tmp/k3b.tZYhjk

Note: this is just a warning issued by mkisofs, but k3b stops at this point.
Comment 5 Adriaan de Groot freebsd_committer 2018-09-06 21:16:49 UTC
*** Bug 231002 has been marked as a duplicate of this bug. ***
Comment 6 Adriaan de Groot freebsd_committer 2019-04-14 21:12:48 UTC
With the BSDISKS backend in Solid (I didn't feel like adding HAL to my system today); this needs the very-very latest version though.

 - start k3b
 - click "New Data Project"
 - RMB on something in the file widget (top half), choose "Add to Project"
 - Wait for that to Import; repeat as necessary
 - Click "Burn" in the data widget (bottom half)
 - You can pick "Create image only" if you like, to save CDs

You can see the warning, still:

```
***** mkisofs calculate size parameters:
"/usr/local/bin/mkisofs -gui -graft-points -print-size -quiet -volid Mail -volset  -appid K3B THE CD KREATOR (C) 1998-2018 SEBASTIAN TRUEG, MICHAL MALEK AND LESLIE ZHAI -publisher  -preparer  -sysid FREEBSD -volset-size 1 -volset-seqno 1 -sort /tmp/k3b.ckebdN -rational-rock -hide-list /tmp/k3b.OGqPFs -joliet -joliet-long -hide-joliet-list /tmp/k3b.OHeDrk -no-cache-inodes -full-iso9660-filenames -disable-deep-relocation -iso-level 3 -path-list /tmp/k3b.pMlVKW" 

started
(mkisofs)  "mkisofs: Warning: Cannot add inode hints with -no-cache-inodes."
(K3b::Device::openDevice) open device  /dev/cd0  succeeded. 
```

However, I'm not seeing the hang that Thierry reported.

I'm going to leave this open for now (and commit an update in a moment that adds libburn to the deps), and when newer bsdisks lands I'll close this one as well as "can't reproduce, presumed fixed".
Comment 7 commit-hook freebsd_committer 2019-04-14 21:41:56 UTC
A commit references this bug:

Author: adridg
Date: Sun Apr 14 21:41:23 UTC 2019
New revision: 498952
URL: https://svnweb.freebsd.org/changeset/ports/498952

Log:
  sysutils/k3b Add missing runtime dependencies

   - While libburn and cdrskin aren't *mandatory*, it's nicer to have
     them by default and avoids a warning popup on start.
   - Polish up the pkg-message to better match current usage, and mention
     the (preferred) BSDISKS option for Solid.

  PR:		228408

Changes:
  head/sysutils/k3b/Makefile
  head/sysutils/k3b/pkg-message
Comment 8 Adriaan de Groot freebsd_committer 2019-04-16 06:59:45 UTC
Closing this one now bsdisks 0.8 has landed. If you switch kf5-solid over to BSDISKS you can certainly use k3b for burning; I have not tried the older HAL backend.