Bug 228441 - audio/lame: Remove RESTRICTED (expired patents)
Summary: audio/lame: Remove RESTRICTED (expired patents)
Status: Closed Not Accepted
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Many People
Assignee: Alexander Leidinger
URL: https://manual.audacityteam.org/man/l...
Keywords: easy, feature, needs-patch
Depends on:
Blocks:
 
Reported: 2018-05-23 17:44 UTC by Bob Frazier
Modified: 2019-12-10 10:54 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (netchild)
koobs: merge-quarterly?


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bob Frazier 2018-05-23 17:44:43 UTC
Reference: 219099 which has been marked 'Closed Overcome by Events'

Please re-open 219099 or address with this bug report.

It has been over a year now since the patent has expired for the mp3 encoding performed by audio/lame.

According to the Audacity web site, the patent licensing restriction is no longer an issue

https://manual.audacityteam.org/man/lame_legal_issues.html

As such it should be ok to remove the patent restrictions in line 17 of Makefile:

RESTRICTED= patent issues

This will allow the package to build, preventing any package dependency difficulties with other packages, such as mencoder.
Comment 1 Alexander Leidinger freebsd_committer 2018-08-07 06:31:12 UTC
I am not only the port maintainer of audio/lame, I'm also one of the project admins of the LAME project. The patent area is NOT clear, no matter what the audacity project claims.

As soon as it is possible to provide packages, I will change the port to do so. Until then it stays like it is (no package distribution). I can not give any ETA about this.