Bug 228499 - net/exabgp upgrade to 4.0.6
Summary: net/exabgp upgrade to 4.0.6
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Ryan Steinmetz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-26 06:23 UTC by Olivier Cochard
Modified: 2019-08-12 21:33 UTC (History)
4 users (show)

See Also:
zi: maintainer-feedback-


Attachments
patch to upgrade exabgp to 4.0.6 (33.71 KB, patch)
2018-05-26 06:23 UTC, Olivier Cochard
no flags Details | Diff
patch to upgrade exabgp to 4.1.2 (31.12 KB, patch)
2019-08-12 21:33 UTC, Olivier Cochard
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Cochard freebsd_committer 2018-05-26 06:23:52 UTC
Created attachment 193707 [details]
patch to upgrade exabgp to 4.0.6

Hi,
here is a proposal for net/exabgp ugprade: With this upgrade, the package name is python-version dependent (become "py36-exabgp 4.0.6" as example).
Comment 1 Ryan Steinmetz freebsd_committer freebsd_triage 2018-05-26 12:11:29 UTC
This is still a pre-release/development version.  The latest stable/official release is 3.4.25.

Do you need features in 4.0.6?
Comment 2 Walter Schwarzenfeld freebsd_triage 2019-02-12 16:59:07 UTC
Version 4.0.10 released.

https://github.com/Exa-Networks/exabgp/releases
Comment 3 Ryan Steinmetz freebsd_committer freebsd_triage 2019-02-12 17:14:28 UTC
4.0.10 is still pre-release.  Rejecting until upstream considers it ready to replace the 3.x branch:

"This version is most likely the last one before we consider the master branch ready to replace 3.4.x."
Comment 4 Leo Vandewoestijne 2019-08-01 13:07:43 UTC
At https://github.com/Exa-Networks/exabgp/releases I now see 4.1.2 having the badge "Latest release".
But does that mean it's a stable release or just the "latest release"?
Reading the comment:

"The control API / CLI command are however not yet frozen and will slightly change before a stable 4.1.0 release."

...plus the name "ISO-release" (for 4.1.1) sounds to me that it became stable last month.

Currently I don't install ExaBGP in production because it requires python 2.7
Comment 5 Olivier Cochard freebsd_committer 2019-08-12 21:33:43 UTC
Created attachment 206480 [details]
patch to upgrade exabgp to 4.1.2