Bug 228536 - x11/nvidia-driver: 11.2-BETA3 - fails to operate correctly
Summary: x11/nvidia-driver: 11.2-BETA3 - fails to operate correctly
Status: Closed Overcome By Events
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 11.1-STABLE
Hardware: amd64 Any
: --- Affects Many People
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
: 231897 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-05-27 08:20 UTC by Ka Ho Ng
Modified: 2019-07-23 04:34 UTC (History)
15 users (show)

See Also:


Attachments
Dmesg of running kernel (11.54 KB, text/plain)
2018-05-27 08:20 UTC, Ka Ho Ng
no flags Details
pkg info nvidia-driver (1.09 KB, text/plain)
2018-05-27 08:21 UTC, Ka Ho Ng
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ka Ho Ng freebsd_committer 2018-05-27 08:20:34 UTC
Created attachment 193754 [details]
Dmesg of running kernel

Suspected KBI breakage happens in FreeBSD 11.2 BETA series as the kld works in FreeBSD 11.1-RELEASE
Comment 1 Ka Ho Ng freebsd_committer 2018-05-27 08:21:04 UTC
Created attachment 193755 [details]
pkg info nvidia-driver
Comment 2 Ka Ho Ng freebsd_committer 2018-05-28 04:06:45 UTC
Since the kmod works after rebuilding, I am thinking there could be a high chance of KBI breakage.
Comment 3 Jonathan M Davis 2018-06-28 09:53:58 UTC
This is still broken in the released version of 11.2. The nvidia-driver package that's available for 11.2 is built for 11.1, not 11.2, and it doesn't work. The module loads, but when X tries to start, it barfs, complaining:

nvidia0: NVRM: rm_init_adapter() failed!

Building the port and installing it fixes the problem, but the package doesn't work, which means that everyone using an nvidia card on 11.2 right now is going to need to build the port themselves.
Comment 4 commit-hook freebsd_committer 2018-06-28 15:31:36 UTC
A commit references this bug:

Author: gjb
Date: Thu Jun 28 15:30:52 UTC 2018
New revision: 335764
URL: https://svnweb.freebsd.org/changeset/base/335764

Log:
  Add an errata entry regarding Bugzilla 228536.

  PR:		228536
  Sponsored by:	The FreeBSD Foundation

Changes:
  stable/11/release/doc/en_US.ISO8859-1/errata/article.xml
Comment 5 Ka Ho Ng freebsd_committer 2018-06-30 04:07:58 UTC
(In reply to Jonathan M Davis from comment #3)

kld built for FreeBSD 11.1 is supposed to work on FreeBSD 11.2 and so on. However due to a KBI bug exposed by r328469 the KBI of vm_map becomes incompatible between 11.1 and 11.2. r332091 was committed to rectify the issue but it only takes effect when nvidia kmod in ports/pkg start to be built against FreeBSD 11.2 kernel. So you currently either need to workaround the issue by rebuilding the ports yourself or waiting till FreeBSD 11.1 is deprecated.
Comment 6 Paco Falcón 2018-07-18 18:37:52 UTC
Hola a todos¡
Estoy en un apuro desde hace días, hace como 4 meses que instalé FreeBSD 11.1 y bueno, estuve bastante entretenido, pero me resultó apasionante y aprendí mucho. Luego aparece hace poco, la versión 11.2 y decidí implementarla a la versión que ya tenía con los parámetros pertinentes que me proponía el Handbook de FreeBSD. Estuvo toda la noche descargándose y configurándose. Salió todo bien, salvo que no reconocía la consola 8 (GUI) y no pude hacerla arrancar. Era una constante la repetición de alarma que hacía, "no existe la ttyv8", cada 25 o 30 segundos. hiciera lo que hiciera, ya fuera estar editando un archivo o estar descargando un paquete, se situaba siempre encima con el susodicho texto, de manera impertinente.
Opté por realizar la instalación desde cero con la versión nueva. Pues llevo casi una semana y no logro salir del bucle que la dichosa Nvidia Geforce 1050 Ti, me tiene metido. Me aparece el mensaje: "nvidia0: NVRM: rm_init_adapter () falló!".
Vengo de Linux y FreeBSD me tiene entusiasmado, sobretodo por el trabajo de consola, que tiene su grado de "adicción", pero ya "no veo luz al final del túnel". Me gustaría que me pudieran orientar un poco, no quisiera volver a la versión anterior, sería un poco frustrante, no me gustaría.
la duda es la que se plantea en este espacio de diálogo. Y parece ser, que se comenta en mas foros, que hay que construir el puerto para NVIDIA, cada cual que tenga el problema. Por eso, mi pregunta va por ahí:
Como se construye el puerto? Lugares, sitios, comandos, referencias o bibliografía para poder llevar a cabo dicha tarea. Muchas gracias y un saludo para todos. PF.
Comment 7 Dave Cottlehuber freebsd_committer 2018-07-23 09:10:59 UTC
Hi Paco! Welcome to FreeBSD. I used translate.google.com as I don't speak 
Spanish. I'll put some quick notes on how to build this package from source
here but if you have any trouble please open a conversation on
https://forums.freebsd.org/ there, in English if you can. Its
normal to use a new post or bug for a different issue.

This assumes you included src and ports during installation.

Hola Paco! Bienvenido a FreeBSD. Utilicé translate.google.com porque no hablo
Español. Voy a poner algunas notas rápidas sobre cómo construir este paquete
desde la fuente aquí, pero si tienes algún problema, abre una conversación
sobre https://forums.freebsd.org/ allí, en inglés si puedes. Sus es normal
usar una nueva publicación o error para un problema diferente.

Esto supone que incluyó src y puertos durante la instalación.

# as root
pkg delete nvidia-driver
cd /usr/ports/x11/nvidia-driver
make package install clean

I don't load drivers in /boot/loader.conf if possible, as it's easier to fix
issues if they are loaded later on.

# put this in /etc/rc.conf
kld_list="${kld_list} nvidia-modeset"

then reboot and good luck!
Comment 8 Paco Falcón 2018-07-26 08:29:43 UTC
Hola Dave!!
Te envío un saludo muy grato y respetuoso.
Muchas gracias por la atención y tú interés en aportarme tu experiencia. 
Fue inspiradora tu respuesta, pero no terminó de resolver mi angustia, seguía resistiendose. Opté por entrar al sitio que me sugeriste, pero no encontraba la forma de comunicarme de manera que obtuviera respuesta positiva y práctica. Repetí la instalación en 4 ocasiones !! En cada una de ellas probaba distintas opciones que había rescatado de otras experiencia y, al final obtuve una alegría al ver que "startx" se convertía en la GUI básica que ofrece Xorg. Ya todo lo posterior no tiene problemas para mi.
Otro sitio que obtuve parte de la respuesta fue en: https://sempreupdate.com.br/como-instalar-driver-nvidia-geforce-gtx-1050ti-no-freebsd/
Muchas gracias de nuevo por tu generosidad !! Un saludo y que estés bien !!
Comment 9 Kalero 2018-09-02 13:31:44 UTC
Does this known bug also apply to nvidia-driver-340? I'm going to install FreeBSD-11.2-RELEASE and I have an NVIDIA GeForce 210, so I have to install nvidia-driver-340. Thanks.
Comment 10 Lena 2018-09-02 13:35:24 UTC
> Does this known bug also apply to nvidia-driver-340?

Yes. Install from ports (make or portupgrade/portmaster). I have almost all others installed from packages.
Comment 11 Kalero 2018-09-02 14:06:29 UTC
(In reply to Lena from comment #10)
Well, while I was waiting for an answer, I installed FreeBSD-11.2-RELEASE, installed nvidia-driver-340 from ports and, to check if the binary package also worked, removed the port with "make deinstall clean" and installed the nvidia-driver-340 binary package with pkg. My surprise was it works, so after reading your answer I don't understand why after deinstalling the port and installing the binary package it's working.
Comment 12 Tijl Coosemans freebsd_committer 2018-11-09 21:19:50 UTC
FreeBSD 11 packages are built for 11.2 now.
Comment 13 Tijl Coosemans freebsd_committer 2018-11-09 21:20:27 UTC
*** Bug 231897 has been marked as a duplicate of this bug. ***
Comment 14 zain david 2019-07-23 04:34:23 UTC
MARKED AS SPAM