Bug 228637 - editors/lazarus: fails to build with lld as system linker
Summary: editors/lazarus: fails to build with lld as system linker
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Jose Alonso Cardenas Marquez
URL:
Keywords:
Depends on:
Blocks: 214864
  Show dependency treegraph
 
Reported: 2018-05-31 13:43 UTC by Ed Maste
Modified: 2018-08-27 03:48 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (acm)


Attachments
Proposed patch for editors/lazrus (470 bytes, patch)
2018-08-26 18:10 UTC, Nick Wolff
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ed Maste freebsd_committer 2018-05-31 13:43:02 UTC
See http://package18.nyi.freebsd.org/data/headamd64PR214864cxx98-default/2018-05-29_20h14m12s/logs/errors/lazarus-gtk2-1.8.2.log

editors/lazarus, editors/lazarus-qt4, editors/lazarus-qt5:
../tools/svn2revisioninc .. revision.inc
gmake[2]: *** [Makefile:4378: revisioninc] Segmentation fault (core dumped)

I was not able to reproduce the failure - it worked for me.
Comment 1 Jose Alonso Cardenas Marquez freebsd_committer 2018-06-03 05:32:26 UTC
did you have applied patch file from https://bugs.freepascal.org/view.php?id=32900 to lang/fpc? or did you have some extra config on 12-CURRENT?
Comment 2 Ed Maste freebsd_committer 2018-07-30 15:37:08 UTC
(In reply to Jose Alonso Cardenas Marquez from comment #1)
I tested just now by installing the FreeBSD fpc package and building editors/lazarus and did not encounter the segfault. I do have four patches in my ports tree, but none that should be related:

- bsd.port.mk reproducible build chang to set SOURCE_DATE_EPOCH in environment
- MAKE_ENV+= LOG=info in java/openjdk8/Makefile
- ports-mgmt/pkg change to use sys/capsicum.h instead of sys/capability.h
- print/gl2ps setting LLD_UNSAFE=yes

I ran:
# pkg install fpc
% cd editors/lazarus
% make

I notice the segfault occurred in svn2revisioninc -- maybe the error happens only if the ports tree is/is not a svn checkout (i.e., if 'svn info' or similar command is or is not successful)
Comment 3 Nick Wolff 2018-08-26 18:10:22 UTC
Created attachment 196576 [details]
Proposed patch for editors/lazrus

This patch fixes the issues on my builds. More LLD issues it seems. I tried just adding USESVN2REVISIONINC=0 to make_args first but this seemed to cause other issues.

My ports tree is checked out via git not svn just as an fyi.