Bug 228639 - games/hedgewars: fails to link with lld as system linker due to invalid section headers
Summary: games/hedgewars: fails to link with lld as system linker due to invalid secti...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Dmitry Marakasov
URL:
Keywords:
Depends on:
Blocks: 214864
  Show dependency treegraph
 
Reported: 2018-05-31 13:48 UTC by Ed Maste
Modified: 2018-06-22 18:47 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (amdmi3)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ed Maste freebsd_committer 2018-05-31 13:48:49 UTC
From http://package18.nyi.freebsd.org/data/headamd64PR214864cxx98-default/2018-05-29_20h14m12s/logs/errors/hedgewars-0.9.24.1.log

/usr/bin/ld: error: /wrkdirs/usr/ports/games/hedgewars/work/hedgewars-src-0.9.24.1/hedgewars/CMakeFiles/hwengine.dir/uConsts.o: invalid alignment of section headers

Root cause of invalid .o file should be identified and fixed, but adding LLD_UNSAFE=yes to the port's Makefile may be a sufficient short-term workaround.
Comment 1 commit-hook freebsd_committer 2018-06-22 18:47:50 UTC
A commit references this bug:

Author: amdmi3
Date: Fri Jun 22 18:47:37 UTC 2018
New revision: 473056
URL: https://svnweb.freebsd.org/changeset/ports/473056

Log:
  - Attempt to fix build with lld

  PR:		228639
  Submitted by:	emaste

Changes:
  head/games/hedgewars/Makefile