Bug 228699 - www/webkit2-gtk3: fix build on aarch64
Summary: www/webkit2-gtk3: fix build on aarch64
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: arm64 Any
: --- Affects Only Me
Assignee: Kurt Jaeger
URL:
Keywords:
: 228700 (view as bug list)
Depends on:
Blocks: 201763
  Show dependency treegraph
 
Reported: 2018-06-02 17:05 UTC by mikael.urankar
Modified: 2018-11-09 15:49 UTC (History)
6 users (show)

See Also:
pi: maintainer-feedback-


Attachments
patch (1.40 KB, patch)
2018-06-02 17:05 UTC, mikael.urankar
no flags Details | Diff
Corrected patch currently under test (3.50 KB, patch)
2018-06-13 04:22 UTC, Mark Linimon
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description mikael.urankar 2018-06-02 17:05:09 UTC
Created attachment 193939 [details]
patch

error log:
FAILED: Source/JavaScriptCore/CMakeFiles/JavaScriptCore.dir/llint/LowLevelInterpreter.cpp.o
/nxb-bin/usr/bin/c++  -DBUILDING_GTK__=1 -DBUILDING_JavaScriptCore -DBUILDING_WITH_CMAKE=1 -DDATA_DIR=\"share\" -DGETTEXT_PACKAGE=\"WebKit2GTK-4.0\" -DHAVE_CONFIG_H=1 -DJavaScriptCore_EXPORTS -DLIBDIR=\"/usr/local/lib\" -DSTATICALLY_LINKED_WITH_WTF -DWEBKITGTK_API_VERSION_STRING=\"4.0\" -IDerivedSources/ForwardingHeaders -isystem /usr/local/include/glib-2.0 -isystem /usr/local/lib/glib-2.0/include -I. -I/wrkdirs/usr/ports/www/webkit2-gtk3/work/webkitgtk-2.20.2/Source/JavaScriptCore -I/wrkdirs/usr/ports/www/webkit2-gtk3/work/webkitgtk-2.20.2/Source/JavaScriptCore/API -I/wrkdirs/usr/ports/www/webkit2-gtk3/work/webkitgtk-2.20.2/Source/JavaScriptCore/assembler -I/wrkdirs/usr/ports/www/webkit2-gtk3/work/webkitgtk-2.20.2/Source/JavaScriptCore/b3 -I/wrkdirs/usr/ports/www/webkit2-gtk3/work/webkitgtk-2.20.2/Source/JavaScriptCore/b3/air -I/wrkdirs/usr/ports/www/webkit2-gtk3/work/webkitgtk-2.20.2/Source/JavaScriptCore/bindings -I/wrkdirs/usr/ports/www/webkit2-gtk3/work/webkitgtk-2.20.2/Source/JavaScriptCore/builtins -I/wrkdirs/usr/ports/www/webkit2-gtk3/work/webkitgtk-2.20.2/Source/JavaScriptCore/bytecode -I/wrkdirs/usr/ports/www/webkit2-gtk3/work/webkitgtk-2.20.2/Source/JavaScriptCore/bytecompiler -I/wrkdirs/usr/ports/www/webkit2-gtk3/work/webkitgtk-2.20.2/Source/JavaScriptCore/dfg -I/wrkdirs/usr/ports/www/webkit2-gtk3/work/webkitgtk-2.20.2/Source/JavaScriptCore/disassembler -I/wrkdirs/usr/ports/www/webkit2-gtk3/work/webkitgtk-2.20.2/Source/JavaScriptCore/disassembler/ARM64 -I/wrkdirs/usr/ports/www/webkit2-gtk3/work/webkitgtk-2.20.2/Source/JavaScriptCore/disassembler/ARMv7 -I/wrkdirs/usr/ports/www/webkit2-gtk3/work/webkitgtk-2.20.2/Source/JavaScriptCore/disassembler/udis86 -I/wrkdirs/usr/ports/www/webkit2-gtk3/work/webkitgtk-2.20.2/Source/JavaScriptCore/domjit -I/wrkdirs/usr/ports/www/webkit2-gtk3/work/webkitgtk-2.20.2/Source/JavaScriptCore/ftl -I/wrkdirs/usr/ports/www/webkit2-gtk3/work/webkitgtk-2.20.2/Source/JavaScriptCore/heap -I/wrkdirs/usr/ports/www/webkit2-gtk3/work/webkitgtk-2.20.2/Source/JavaScriptCore/debugger -I/wrkdirs/usr/ports/www/webkit2-gtk3/work/webkitgtk-2.20.2/Source/JavaScriptCore/inspector -I/wrkdirs/usr/ports/www/webkit2-gtk3/work/webkitgtk-2.20.2/Source/JavaScriptCore/inspector/agents -I/wrkdirs/usr/ports/www/webkit2-gtk3/work/webkitgtk-2.20.2/Source/JavaScriptCore/inspector/augmentable -I/wrkdirs/usr/ports/www/webkit2-gtk3/work/webkitgtk-2.20.2/Source/JavaScriptCore/inspector/remote -I/wrkdirs/usr/ports/www/webkit2-gtk3/work/webkitgtk-2.20.2/Source/JavaScriptCore/interpreter -I/wrkdirs/usr/ports/www/webkit2-gtk3/work/webkitgtk-2.20.2/Source/JavaScriptCore/jit -I/wrkdirs/usr/ports/www/webkit2-gtk3/work/webkitgtk-2.20.2/Source/JavaScriptCore/llint -I/wrkdirs/usr/ports/www/webkit2-gtk3/work/webkitgtk-2.20.2/Source/JavaScriptCore/parser -I/wrkdirs/usr/ports/www/webkit2-gtk3/work/webkitgtk-2.20.2/Source/JavaScriptCore/profiler -I/wrkdirs/usr/ports/www/webkit2-gtk3/work/webkitgtk-2.20.2/Source/JavaScriptCore/runtime -I/wrkdirs/usr/ports/www/webkit2-gtk3/work/webkitgtk-2.20.2/Source/JavaScriptCore/tools -I/wrkdirs/usr/ports/www/webkit2-gtk3/work/webkitgtk-2.20.2/Source/JavaScriptCore/wasm -I/wrkdirs/usr/ports/www/webkit2-gtk3/work/webkitgtk-2.20.2/Source/JavaScriptCore/wasm/js -I/wrkdirs/usr/ports/www/webkit2-gtk3/work/webkitgtk-2.20.2/Source/JavaScriptCore/yarr -IDerivedSources/JavaScriptCore -IDerivedSources/JavaScriptCore/inspector -IDerivedSources/JavaScriptCore/runtime -IDerivedSources/JavaScriptCore/yarr -I/wrkdirs/usr/ports/www/webkit2-gtk3/work/webkitgtk-2.20.2/Source/JavaScriptCore/inspector/remote/glib -I/wrkdirs/usr/ports/www/webkit2-gtk3/work/webkitgtk-2.20.2/Source/bmalloc -IDerivedSources -I/wrkdirs/usr/ports/www/webkit2-gtk3/work/webkitgtk-2.20.2/Source/ThirdParty -fdiagnostics-color=always -fcolor-diagnostics -Wno-parentheses-equality -Wno-noexcept-type -Qunused-arguments -Wwrite-strings -Wundef -Wpointer-arith -Wmissing-format-attribute -Wformat-security -Wcast-align -Wextra -Wall -O2 -pipe -DNDEBUG -isystem /usr/local/include -fno-strict-aliasing  -DFIXED_EXECUTABLE_MEMORY_POOL_SIZE_IN_MB=32 -B/usr/bin -isystem /usr/local/include -fno-strict-aliasing -fno-exceptions -std=c++14 -fno-rtti -O2 -pipe -DNDEBUG -isystem /usr/local/include -fno-strict-aliasing  -DFIXED_EXECUTABLE_MEMORY_POOL_SIZE_IN_MB=32 -B/usr/bin -isystem /usr/local/include -fPIC -MD -MT Source/JavaScriptCore/CMakeFiles/JavaScriptCore.dir/llint/LowLevelInterpreter.cpp.o -MF Source/JavaScriptCore/CMakeFiles/JavaScriptCore.dir/llint/LowLevelInterpreter.cpp.o.d -o Source/JavaScriptCore/CMakeFiles/JavaScriptCore.dir/llint/LowLevelInterpreter.cpp.o -c /wrkdirs/usr/ports/www/webkit2-gtk3/work/webkitgtk-2.20.2/Source/JavaScriptCore/llint/LowLevelInterpreter.cpp
In file included from /wrkdirs/usr/ports/www/webkit2-gtk3/work/webkitgtk-2.20.2/Source/JavaScriptCore/llint/LowLevelInterpreter.cpp:559:
DerivedSources/JavaScriptCore/LLIntAssembly.h:792:2: error: Missing globaladdr implementation
#error Missing globaladdr implementation

The attached patch fixes the issue.
Comment 1 mikael.urankar 2018-06-02 17:16:20 UTC
*** Bug 228700 has been marked as a duplicate of this bug. ***
Comment 2 Mark Linimon freebsd_committer freebsd_triage 2018-06-13 04:22:58 UTC
Created attachment 194211 [details]
Corrected patch currently under test
Comment 3 w.schwarzenfeld freebsd_triage 2018-06-18 20:29:58 UTC
webkit2-gtk3 is updated to 2.20.3

The added lines  now exists in the files which are wanted to patched.

I cannot test on aarch64. Please, test if it builds now with the new version.
Comment 4 Greg V 2018-07-11 21:41:27 UTC
The "Corrected patch currently under test" is indeed unnecessary, and it's completely unrelated.

The original patch, attachment 193939 [details] ($asm.putStr("#elif OS(LINUX) || OS(FREEBSD)")) is still necessary. The package builds successfully with that one line change.
Comment 5 Andrew Turner freebsd_committer 2018-09-09 09:23:05 UTC
Is there anything holding up committing the first patch? It looks correct from an arm64 assembly point of view, and the webkit2-gtk3 port is blocking 170-240 other ports.
Comment 6 Greg V 2018-10-22 12:02:37 UTC
ping gnome@
Comment 7 Kurt Jaeger freebsd_committer 2018-11-09 15:48:04 UTC
Committed, thanks.
Comment 8 commit-hook freebsd_committer 2018-11-09 15:48:36 UTC
A commit references this bug:

Author: pi
Date: Fri Nov  9 15:47:47 UTC 2018
New revision: 484519
URL: https://svnweb.freebsd.org/changeset/ports/484519

Log:
  www/webkit2-gtk3: fix build on aarch64

  PR:		228699
  Submitted by:	mikael.urankar@gmail.com
  Reviewed by:	greg@unrelenting.technology

Changes:
  head/www/webkit2-gtk3/files/patch-Source_JavaScriptCore_offlineasm_arm64_rb