Bug 228734 - devel/aarch64-none-elf-gcc: pkg-plist errors after latest commit
Summary: devel/aarch64-none-elf-gcc: pkg-plist errors after latest commit
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Ryan Steinmetz
URL:
Keywords:
Depends on:
Blocks: 201763
  Show dependency treegraph
 
Reported: 2018-06-04 04:34 UTC by Phillip R. Jaenke
Modified: 2018-08-12 20:00 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (kan)


Attachments
devel_aarch64-none-elf-gcc_pkg-plist.patch (646 bytes, patch)
2018-08-12 18:52 UTC, Phillip R. Jaenke
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Phillip R. Jaenke 2018-06-04 04:34:55 UTC
Observed in poudriere, reproducible since 469834

====> Compressing man pages (compress-man)
===========================================================================
====> Running Q/A tests (stage-qa)
====> Checking for pkg-plist issues (check-plist)
===> Parsing plist
===> Checking for items in STAGEDIR missing from pkg-plist
Error: Orphaned: bin/%%GCC_TARGET%%-gcov-dump
Error: Orphaned: man/man1/%%GCC_TARGET%%-gcov-dump.1.gz
Error: Orphaned: man/man1/%%GCC_TARGET%%-gcov-tool.1.gz
===> Checking for items in pkg-plist which are not in STAGEDIR
===> Error: Plist issues found.
*** Error code 1

Stop.
make: stopped in /usr/ports/devel/aarch64-none-elf-gcc
=>> Error: check-plist failures detected
=>> Cleaning up wrkdir

Not sure of the fix to this one; whether these pieces are needed or not.
Comment 1 Phillip R. Jaenke 2018-08-12 18:52:10 UTC
Created attachment 196135 [details]
devel_aarch64-none-elf-gcc_pkg-plist.patch
Comment 2 Phillip R. Jaenke 2018-08-12 18:58:37 UTC
No maintainer response in 2 months. Going to assume these files can safely be installed. Tested and confirmed patch attached. Requesting a maintainer timeout. This one should also probably be MFH'd to quarterly since it's a relatively minor fix and impacts a number of dependent ports.

http://poudriere.rootwyrm.com/data/FreeBSD:11:i386-default-production/2018-08-12_14h51m43s/logs/aarch64-none-elf-gcc-6.4.0_2.log
Comment 3 Ryan Steinmetz freebsd_committer freebsd_triage 2018-08-12 19:53:04 UTC
Confirmed pkg-plist issue.
Comment 4 commit-hook freebsd_committer 2018-08-12 19:59:15 UTC
A commit references this bug:

Author: zi
Date: Sun Aug 12 19:58:47 UTC 2018
New revision: 477038
URL: https://svnweb.freebsd.org/changeset/ports/477038

Log:
  - Fix pkg-plist issue

  PR:		228734
  Submitted by:	prj@rootwyrm.com
  Approved by:	maintainer timeout (2+ months)

Changes:
  head/devel/aarch64-none-elf-gcc/pkg-plist