Bug 228835 - [UPDATE] net/ipxe: update to 20180514 & fix embedding of custom trusted certs
Summary: [UPDATE] net/ipxe: update to 20180514 & fix embedding of custom trusted certs
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Tobias Kortkamp
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-06-08 20:29 UTC by Chad Jacob Milios
Modified: 2018-06-10 10:03 UTC (History)
0 users

See Also:
tobik: maintainer-feedback+


Attachments
svn diff from /usr/ports (2.54 KB, patch)
2018-06-08 20:29 UTC, Chad Jacob Milios
no flags Details | Diff
ipxe.diff (1.87 KB, patch)
2018-06-09 18:17 UTC, Tobias Kortkamp
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Chad Jacob Milios 2018-06-08 20:29:35 UTC
Created attachment 194084 [details]
svn diff from /usr/ports

Instructions at http://ipxe.org/crypto didn't work. First I tried patching the software to work with the base csplit but for the life of me I could not get it to work right so I just went ahead and added the dependency on gcsplit which works fabulously.

Also bumped the version to the latest.
Comment 1 Tobias Kortkamp freebsd_committer 2018-06-09 18:17:48 UTC
Created attachment 194110 [details]
ipxe.diff

I can confirm the csplit problem, but it makes no sense to add a
coreutils build dependency to the ISO option.  The certificate is
embdedded into every image net/ipxe builds not only the ISO.

We also only need this when CERT= is set in MAKE_ARGS, so let's
only add it in that case.  Not everyone needs it.

Please try with the attached patch instead.
Comment 2 Chad Jacob Milios 2018-06-09 21:11:19 UTC
Yeah, that line being added only within ISO_* was an oversight and mistake. Your make-fu is much nicer with the conditional dependency; that's exactly what I wanted to do but I wasn't sure how. I was also unsure whether it was CERT or TRUST which triggered csplit, as I am using both. I've since tested your patch every different way I know how and can report it seems perfect to me. (I see you didn't need the extra patch-Makefile and I got rid of it first too.)

Thank you so much for the super quick turnaround on this, maintainer!
Comment 3 commit-hook freebsd_committer 2018-06-10 10:03:04 UTC
A commit references this bug:

Author: tobik
Date: Sun Jun 10 10:02:56 UTC 2018
New revision: 472124
URL: https://svnweb.freebsd.org/changeset/ports/472124

Log:
  net/ipxe: Update to latest commit

  Pull in gcsplit from sysutils/coreutils when users try to embed
  certificates via CERT= in MAKE_ARGS.  This currently fails because
  iPXE expects csplit to behave like GNU csplit and uses constructs
  that our csplit does not support.

  PR:		228835
  Submitted by:	Chad Jacob Milios <milios@ccsys.com> (based on)

Changes:
  head/net/ipxe/Makefile
  head/net/ipxe/distinfo
Comment 4 Tobias Kortkamp freebsd_committer 2018-06-10 10:03:40 UTC
Committed. Thanks!