Bug 228867 - www/neon: Fails to build with OpenSSL 1.1
Summary: www/neon: Fails to build with OpenSSL 1.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Lev A. Serebryakov
URL:
Keywords:
Depends on:
Blocks: 228865 231931
  Show dependency treegraph
 
Reported: 2018-06-10 11:20 UTC by Bernard Spil
Modified: 2018-10-19 13:47 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (lev)


Attachments
Poudriere build log (16.33 KB, text/plain)
2018-06-10 11:20 UTC, Bernard Spil
no flags Details
FIxed compile (1.22 KB, patch)
2018-09-15 18:39 UTC, Nathan
no flags Details | Diff
Fix OpenSSL 1.x build (498 bytes, patch)
2018-10-05 00:29 UTC, Nathan
no flags Details | Diff
Fix OpenSSL build (2.21 KB, patch)
2018-10-05 11:12 UTC, Nathan
no flags Details | Diff
Fix build with OpenSSL 1.1. (436 bytes, patch)
2018-10-10 22:07 UTC, Jung-uk Kim
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Bernard Spil freebsd_committer 2018-06-10 11:20:32 UTC
Created attachment 194126 [details]
Poudriere build log

Currently www/neon fails to build with OpenSSL 1.1

Plan is to update base OpenSSL to 1.1 in 12 so ports will have to be compatible as well.
Comment 1 Lev A. Serebryakov freebsd_committer 2018-06-10 12:01:42 UTC
Looks like we should delete neon from ports. It is unsupported, doesn't have upstream anymore and is not used by subversion (which was main driver to add neon to ports in first place).

There were release 0.30.2 which fixes this particular problem, but it is not clear, where should we download source tarball, as homepage of neon is gone 1.5 years ago. 

Page itself is accessible via webarchive.org, but not tarball.

Tarball could be found on some FTP sites, but it doesn't look good idea to rely on it.

On the other hand, there are some other ports, which depends on it, including LibreOffice…

Uh-oh…

Looks like we need mirror source tarball and update port.
Comment 2 commit-hook freebsd_committer 2018-06-18 15:27:28 UTC
A commit references this bug:

Author: lev
Date: Mon Jun 18 15:26:34 UTC 2018
New revision: 472704
URL: https://svnweb.freebsd.org/changeset/ports/472704

Log:
   Update to latest version 0.30.2, which should support OpenSSL 1.1.x
   Move distfile to LOCAL, as upstream site is dead.

  PR:		228867

Changes:
  head/www/neon/Makefile
  head/www/neon/distinfo
  head/www/neon/pkg-plist
Comment 3 Lev A. Serebryakov freebsd_committer 2018-06-18 15:29:00 UTC
Should be fixed now
Comment 4 Bernard Spil freebsd_committer 2018-08-17 13:49:58 UTC
Hi Lev,

Re-opening as this still has issues. It fails in poudriere yet it was successful in my porting jail. Difference was the use of pkg-config which changes the way configure operates.
See: https://keg.brnrd.eu/data/111amd64-default-openssl111/2018-08-14_10h01m04s/logs/errors/neon-0.30.2_1.log

Without pkg-config:
> checking whether to enable ACL support in neon... yes
> checking for pkg-config... no
> checking for library containing RSA_new... -lcrypto
> checking for library containing SSL_library_init... not found
> configure: error: could not find library containing SSL_library_init
> ===>  Script "configure" failed unexpectedly.

With pkg-config:
> checking for pkg-config... /usr/local/bin/pkg-config
> checking for openssl pkg-config data... yes
> configure: using SSL library configuration from pkg-config
> checking openssl/ssl.h usability... yes
> checking openssl/ssl.h presence... yes
> checking for openssl/ssl.h... yes
> checking openssl/opensslv.h usability... yes
> checking openssl/opensslv.h presence... yes
> checking for openssl/opensslv.h... yes
> checking OpenSSL version is >= 0.9.7... yes
> configure: OpenSSL >= 0.9.7; EGD support not needed in neon
> configure: SSL support enabled, using OpenSSL (0.9.7 or later)
> checking for CRYPTO_set_idptr_callback... no
> checking for SSL_SESSION_cmp... no
> configure: Using /usr/local/share/certs/ca-root-nss.crt as default SSL CA bundle

Arguably, the check for SSL_library_init should be removed from configure as that's non-existent and checked for in the code 
> #if OPENSSL_VERSION_NUMBER < 0x10100000L
>     CRYPTO_malloc_init();
>     SSL_load_error_strings();
>     SSL_library_init();

Cheers, Bernard.
Comment 5 Nathan 2018-09-15 18:39:18 UTC
Created attachment 197115 [details]
FIxed compile

Patch fixed compile for openssl-devel 1.1.0i for me
Comment 7 Nathan 2018-10-05 00:29:59 UTC
Created attachment 197803 [details]
Fix OpenSSL 1.x build

 www/neon: Fix OpenSSL-devel build
 
 PR:             228867
 Submitted by:   Nathan <ndowens@yahoo.com>
Comment 8 Bernard Spil freebsd_committer 2018-10-05 08:49:19 UTC
(In reply to Nathan from comment #7)
Hi Nathan, this new patch only contains a revision bump. Did you perhaps forget to do a svn add on the patch file?
Comment 9 Lev A. Serebryakov freebsd_committer 2018-10-05 09:51:37 UTC
Are you sure patch is correct? It does virtually nothing.
Comment 10 Nathan 2018-10-05 11:01:58 UTC
(In reply to Bernard Spil from comment #8)
Oops I’ll fix that ASAP
Comment 11 Nathan 2018-10-05 11:12:24 UTC
Created attachment 197809 [details]
Fix OpenSSL build
Comment 12 commit-hook freebsd_committer 2018-10-05 12:22:17 UTC
A commit references this bug:

Author: lev
Date: Fri Oct  5 12:21:47 UTC 2018
New revision: 481274
URL: https://svnweb.freebsd.org/changeset/ports/481274

Log:
   Fix build with openssl 1.1.1

  PR:		228867
  Submitted by:	brnrd@freebsd.org

Changes:
  head/www/neon/Makefile
  head/www/neon/files/
  head/www/neon/files/patch-configure
Comment 13 Lev A. Serebryakov freebsd_committer 2018-10-05 12:23:20 UTC
Committed, thnx!
Comment 14 commit-hook freebsd_committer 2018-10-06 05:46:24 UTC
A commit references this bug:

Author: antoine
Date: Sat Oct  6 05:46:03 UTC 2018
New revision: 481319
URL: https://svnweb.freebsd.org/changeset/ports/481319

Log:
  Revert r481274, it broke ports depending on neon

  PR:		228867
  With hat:	portmgr
  Reported by:	pkg-fallout

Changes:
  head/www/neon/Makefile
  head/www/neon/files/
Comment 15 Antoine Brodin freebsd_committer 2018-10-06 05:47:04 UTC
Re-open, the patch was wrong and reverted.
Comment 16 Nathan 2018-10-06 05:54:19 UTC
(In reply to Antoine Brodin from comment #15)
Which ports did this break?
Comment 18 Nathan 2018-10-08 01:29:56 UTC
(In reply to Antoine Brodin from comment #17)
I tested libmusicbrainz with openssl 1.1 & openssl-base build and it didn't give me an error like the build log shows
Comment 19 Antoine Brodin freebsd_committer 2018-10-08 17:43:34 UTC
(In reply to Nathan from comment #18)
In fact, all the ports depending on neon broke with the previous patch...
Comment 20 Jung-uk Kim freebsd_committer 2018-10-10 22:07:17 UTC
Created attachment 198017 [details]
Fix build with OpenSSL 1.1.

This patch should fix the problem.  Because SSL_library_init() does not exist in OpenSSL 1.1, there is no point of guessing.  However, we have to make sure -lssl is used for linking libneon.so.
Comment 21 Lev A. Serebryakov freebsd_committer 2018-10-11 11:59:00 UTC
(In reply to Jung-uk Kim from comment #20)
What is status of old OpenSSL? Could it be installed from ports and break neon with this patch?
Comment 22 Jung-uk Kim freebsd_committer 2018-10-11 21:14:09 UTC
(In reply to Lev A. Serebryakov from comment #21)
> What is status of old OpenSSL? Could it be installed from ports and break neon with this patch?

I built www/neon and audio/libmusicbrainz5 on 10.4 and 11.2 and I didn't see any regression.
Comment 23 commit-hook freebsd_committer 2018-10-12 08:46:27 UTC
A commit references this bug:

Author: lev
Date: Fri Oct 12 08:45:36 UTC 2018
New revision: 481885
URL: https://svnweb.freebsd.org/changeset/ports/481885

Log:
   Second try to fix OpenSSL 1.1.1 build.

  PR:		228867
  Submitted by:	jkim@FreeBSD.org

Changes:
  head/www/neon/Makefile
Comment 24 Lev A. Serebryakov freebsd_committer 2018-10-12 22:17:26 UTC
Fixed, thnx!
Comment 25 commit-hook freebsd_committer 2018-10-19 13:47:35 UTC
A commit references this bug:

Author: antoine
Date: Fri Oct 19 13:47:22 UTC 2018
New revision: 482427
URL: https://svnweb.freebsd.org/changeset/ports/482427

Log:
  MFH: r481274 r481319 r481885

   Fix build with openssl 1.1.1

  PR:		228867
  Submitted by:	brnrd@freebsd.org

  Revert r481274, it broke ports depending on neon

  PR:		228867
  With hat:	portmgr
  Reported by:	pkg-fallout

   Second try to fix OpenSSL 1.1.1 build.

  PR:		228867
  Submitted by:	jkim@FreeBSD.org

Changes:
_U  branches/2018Q4/
  branches/2018Q4/www/neon/Makefile
Comment 26 commit-hook freebsd_committer 2018-10-19 13:47:38 UTC
A commit references this bug:

Author: antoine
Date: Fri Oct 19 13:47:22 UTC 2018
New revision: 482427
URL: https://svnweb.freebsd.org/changeset/ports/482427

Log:
  MFH: r481274 r481319 r481885

   Fix build with openssl 1.1.1

  PR:		228867
  Submitted by:	brnrd@freebsd.org

  Revert r481274, it broke ports depending on neon

  PR:		228867
  With hat:	portmgr
  Reported by:	pkg-fallout

   Second try to fix OpenSSL 1.1.1 build.

  PR:		228867
  Submitted by:	jkim@FreeBSD.org

Changes:
_U  branches/2018Q4/
  branches/2018Q4/www/neon/Makefile
Comment 27 commit-hook freebsd_committer 2018-10-19 13:47:40 UTC
A commit references this bug:

Author: antoine
Date: Fri Oct 19 13:47:22 UTC 2018
New revision: 482427
URL: https://svnweb.freebsd.org/changeset/ports/482427

Log:
  MFH: r481274 r481319 r481885

   Fix build with openssl 1.1.1

  PR:		228867
  Submitted by:	brnrd@freebsd.org

  Revert r481274, it broke ports depending on neon

  PR:		228867
  With hat:	portmgr
  Reported by:	pkg-fallout

   Second try to fix OpenSSL 1.1.1 build.

  PR:		228867
  Submitted by:	jkim@FreeBSD.org

Changes:
_U  branches/2018Q4/
  branches/2018Q4/www/neon/Makefile