Bug 228940 - mail/spamassassin: Fails to build with OpenSSL 1.1
Summary: mail/spamassassin: Fails to build with OpenSSL 1.1
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Niclas Zeising
URL:
Keywords:
Depends on:
Blocks: 228865
  Show dependency treegraph
 
Reported: 2018-06-12 14:27 UTC by Bernard Spil
Modified: 2018-12-29 17:46 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (zeising)


Attachments
patch for openssl 1.1.1 (3.73 KB, patch)
2018-12-29 17:46 UTC, Leonard Rucker
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Bernard Spil freebsd_committer 2018-06-12 14:27:24 UTC
> checking for SSL_CTX_free in -lssl... yes
> configure: error: Cannot use SSL; libraries or header files are missing.

During BSDCan 2018 the intention to update OpenSSL in base to 1.1.x branch was documented.

Intention is to update 12-STABLE to current 1.1.0 and subsequently update it to 1.1.1 when that is released.
Comment 1 Niclas Zeising freebsd_committer 2018-08-02 21:01:26 UTC
Is there any build log or similar to show the error, and somewhere to test?
Comment 2 Nathan 2018-09-15 18:51:13 UTC
I got no build error on 11 Jail with openssl-1.1.0i
Comment 3 Nathan 2018-10-15 01:14:16 UTC
Also builds on openssl 1.1
Comment 4 Niclas Zeising freebsd_committer 2018-12-23 10:01:37 UTC
Closing this.

I've had no reports about issues from the ports builder since OpenSSL version was bumped in FreeBSD, and I haven't seen any other logs indicating failure.

This can be reopened if needed.
Comment 5 Leonard Rucker 2018-12-29 17:46:38 UTC
Created attachment 200610 [details]
patch for openssl 1.1.1

patch for openssl build issue