Bug 228993 - lang/julia: fix RUNPATH in 0.6.3
Summary: lang/julia: fix RUNPATH in 0.6.3
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Steve Wills
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-06-13 17:19 UTC by Iblis Lin
Modified: 2018-06-14 23:42 UTC (History)
0 users

See Also:


Attachments
julia 0.6.3_1 patch (6.01 KB, patch)
2018-06-13 17:19 UTC, Iblis Lin
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Iblis Lin 2018-06-13 17:19:23 UTC
Created attachment 194229 [details]
julia 0.6.3_1 patch

Reported by user:
on the startup of `julia`
```
WARNING: Error during initialization of module LinAlg:
ErrorException("could not load library "libopenblasp"
/lib/libgcc_s.so.1: version GCC_4.6.0 required by /usr/local/lib/gcc6/libgfortran.so.3 not found")
WARNING: Error during initialization of module CHOLMOD:
ErrorException|"could not load library "libcholmod"
/usr/local/lib/libcholmod.so.1: Undefined symbol "colamd_printf"")
```

This is caused by RUNPATH overriding during the `install` stage.
Comment 1 commit-hook freebsd_committer 2018-06-14 23:41:10 UTC
A commit references this bug:

Author: swills
Date: Thu Jun 14 23:40:47 UTC 2018
New revision: 472417
URL: https://svnweb.freebsd.org/changeset/ports/472417

Log:
  lang/julia: fix RUNPATH in 0.6.3

  PR:		228993
  Submitted by:	Iblis Lin <iblis@hs.ntnu.edu.tw> (maintainer)

Changes:
  head/lang/julia/Makefile
  head/lang/julia/files/patch-Make.inc
  head/lang/julia/files/patch-Makefile
  head/lang/julia/files/patch-src_Makefile
Comment 2 Steve Wills freebsd_committer 2018-06-14 23:42:32 UTC
Committed, thanks!