Bug 229004 - editors/linux-sublime3: Crashes on startup after 3.1.76 update
Summary: editors/linux-sublime3: Crashes on startup after 3.1.76 update
Status: Closed Not Enough Information
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
Keywords: crash, needs-qa, regression
Depends on:
Blocks: 247219
  Show dependency treegraph
Reported: 2018-06-13 23:02 UTC by Gary
Modified: 2020-08-17 12:22 UTC (History)
6 users (show)

See Also:
bugzilla: maintainer-feedback? (miguelmclara)


Note You need to log in before you can comment on or make changes to this bug.
Description Gary 2018-06-13 23:02:30 UTC
/var/log/messages shows

Jun 13 13:24:40 hostname pkg: linux-sublime3 upgraded: 3.1.43 -> 3.1.76 
Jun 13 13:24:46 hostname kernel: linux: pid 47880 (io_worker): syscall inotify_init not implemented
Jun 13 13:24:47 hostname kernel: pid 47882 (update_check), uid 1001: exited on signal 6
Jun 13 13:24:47 hostname kernel: pid 47880 (update_check), uid 1001: exited on signal 6

3.1.43 works fine.  I went back to the old version.

There may be more problems than the SIGABRT in update_check, not sure

% freebsd-version -ku
Comment 1 Tijl Coosemans freebsd_committer 2018-12-16 13:20:20 UTC
Is this still a problem?
Comment 2 Gary 2018-12-16 13:39:31 UTC
Just tried on 11.2-RELEASE-p6 with linux-sublime3-3.1.76 - same behaviour.

linux: pid 43534 (io_worker): syscall inotify_init not implemented
pid 43536 (file_read_threa), uid 1001: exited on signal 6
pid 43534 (file_read_threa), uid 1001: exited on signal 6

Although I moved ~/.config/sublime-text-3 out of the way and it was able to start.  Not entirely sure why, and makes me wonder if it will start crashing again during use.
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2018-12-17 04:47:14 UTC
I wonder if file system notifications can be disabled in settings.
Comment 4 Tijl Coosemans freebsd_committer 2018-12-17 10:58:19 UTC
Missing inotify is not causing this.  It has always printed that message.  I think this can be closed now.  It must have been an upstream bug where the new version didn't handle the old config file properly or something.
Comment 5 Kubilay Kocak freebsd_committer freebsd_triage 2018-12-17 11:00:37 UTC
(In reply to Gary from comment #2)

If you can identify which setting(s) are causing the issue that might help elucidate something more concrete to report upstream
Comment 6 Robert Cina 2019-09-29 09:51:28 UTC
I have just installed linux-sublime3 on my 12.1-Stable amd64 system and I find it does not start for me. Typing sublime at the terminal does not appear to show any relevant error message as it just returns to the shell prompt. 
Typing the following at the prompt returns:

% sublime -v
Sublime Text Build 3176

I am not sure what the issue is or how I would go about troubleshooting it to get the port to work. Any thoughts appreciated.
Comment 7 miguel.barao 2019-10-16 12:31:50 UTC
On 12.0-RELEASE I downloaded the latest sublime-text-3 version 3.2.2 build 3211 for linux-x64.
I managed to make it work fine with the following steps:

sudo pkg install linux-c7-gtk3

### create ~/.local/bin and ~/.local/share if they don't exist
### sublime will be installed in ~/.local for the local user only

tar xvfj sublime_text_3_build_3211_x64.tar.bz2
mv sublime_text_3 ~/.local/share

### edit ~/.local/bin/sublime with these 2 lines:

exec $HOME/.local/share/sublime_text_3/sublime_text "$@"

Make sure .local/bin is in your path.
The linux-sublime3 package can be removed, linux-c7-gtk2 is not required and can also be removed.

It also works with sublime merge. Just repeat the steps above.
Comment 8 Robert Cina 2019-10-17 00:07:09 UTC
I tried the work around suggested but it didn't seem to work for me. I don't know why. I type sublime and at the command line and there is no information error information returned either as with when I use the official port. I am using 12.1 stable however as opposed to 12.0 release so that may be why but who knows.  Either way this port seems broken at the moment for me.
Comment 9 Edward Tomasz Napierala freebsd_committer 2020-06-13 14:49:27 UTC
Seems to work on 13-CURRENT, r362104, installed from linux-sublime3-3.2.2.  Gary, can you still reproduce it?
Comment 10 Gary 2020-08-17 11:57:57 UTC
I traced my crash back to the list of files/windows that sublime keeps to reopen on the next startup.  I had a lot of files open so I have no idea which was the problematic entry, or if it was something else.  Removing that file allowed sublime to start with a clean slate.  I think this can be closed
Comment 11 Tijl Coosemans freebsd_committer 2020-08-17 12:22:27 UTC
Ok.  Feel free to reopen if the problem reappears.