Bug 229005 - devel/cppcheck 1.84 patch fail
Summary: devel/cppcheck 1.84 patch fail
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Dmitry Marakasov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-06-13 23:32 UTC by rozhuk.im
Modified: 2018-06-19 13:48 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (amdmi3)


Attachments
up (425 bytes, patch)
2018-06-13 23:32 UTC, rozhuk.im
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description rozhuk.im 2018-06-13 23:32:51 UTC
Created attachment 194241 [details]
up

Patch for CMakeList.txt need update.
Comment 1 Dmitry Marakasov freebsd_committer 2018-06-14 17:07:10 UTC
Which system version do you use? I've had no patching problems on any supported versions.
Comment 2 rozhuk.im 2018-06-15 15:31:29 UTC
(In reply to Dmitry Marakasov from comment #1)

CMakeLists.txt is in archive, so sysver does no affect it.
11.1+ x64
Comment 3 Dmitry Marakasov freebsd_committer 2018-06-15 16:06:48 UTC
(In reply to rozhuk.im from comment #2)
> (In reply to Dmitry Marakasov from comment #1)
> 
> CMakeLists.txt is in archive, so sysver does no affect it.

Yes, but there could be some changes to patch utility on e.g. CURRENT.

> 11.1+ x64

I have the same version, and it patches fine. Could you please post an output of `make clean patch`?
Comment 4 rozhuk.im 2018-06-16 20:39:24 UTC
===>  Cleaning for cppcheck-1.84
===>  License GPLv3+ accepted by the user
===>   cppcheck-1.84 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by cppcheck-1.84 for building
===>  Extracting for cppcheck-1.84
=> SHA256 Checksum OK for danmar-cppcheck-1.84_GH0.tar.gz.
===>  Patching for cppcheck-1.84
===>  Applying FreeBSD patches for cppcheck-1.84
1 out of 1 hunks failed--saving rejects to CMakeLists.txt.rej
=> FreeBSD patch patch-CMakeLists.txt failed to apply cleanly.
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/devel/cppcheck
*** Error code 1

Stop.
make: stopped in /usr/ports/devel/cppcheck
Exit 1
Comment 5 commit-hook freebsd_committer 2018-06-19 13:45:16 UTC
A commit references this bug:

Author: amdmi3
Date: Tue Jun 19 13:44:20 UTC 2018
New revision: 472785
URL: https://svnweb.freebsd.org/changeset/ports/472785

Log:
  - Regenerate patches, as patching fails in some cases (could not reproduce though)

  PR:		229005
  Reported by:	rozhuk.im@gmail.com

Changes:
  head/devel/cppcheck/files/patch-CMakeLists.txt
  head/devel/cppcheck/files/patch-gui_CMakeLists.txt
Comment 6 Dmitry Marakasov freebsd_committer 2018-06-19 13:48:16 UTC
Hmm, it reproduced in one of my poudrueres, but not in the main one, and still cannot reproduce locally. So let's just regerenerate patches.