Bug 229017 - mail/libesmtp: Configure fails with OpenSSL 1.1
Summary: mail/libesmtp: Configure fails with OpenSSL 1.1
Status: Closed DUPLICATE of bug 238133
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords: needs-patch
Depends on:
Blocks: 228865
  Show dependency treegraph
 
Reported: 2018-06-14 19:52 UTC by Bernard Spil
Modified: 2019-08-18 23:05 UTC (History)
3 users (show)

See Also:


Attachments
Fix OpenSSL 1.1.x build (1.70 KB, patch)
2018-10-09 22:32 UTC, Nathan
ndowens04: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Bernard Spil freebsd_committer 2018-06-14 19:52:51 UTC
> checking for SSL_library_init in -lssl... no
> configure: error: cannot find the ssl library

During BSDCan 2018 the intention to update OpenSSL in base to 1.1.x branch was documented.

Intention is to update 12-STABLE to current 1.1.0 and subsequently update it to 1.1.1 when that is released. 

Poudriere log: https://keg.brnrd.eu/data/111amd64-default-openssl110/2018-06-11_10h42m37s/logs/errors/libesmtp-1.0.6_2,1.log
Comment 1 Nathan 2018-09-03 03:17:11 UTC
===>   libesmtp-1.0.6_2,1 depends on package: openssl-devel>0 - not found
===>   Installing existing package /packages/All/openssl-devel-1.1.0i.txz

I did not get a configure error or anything; it built successfully for me
Comment 2 Bernard Spil freebsd_committer 2018-09-05 17:31:19 UTC
Hmmm...

I get errors in poudriere both with 1.1.0 and 1.1.1

https://keg.brnrd.eu/data/111amd64-default-openssl111/2018-08-14_10h01m04s/logs/errors/libesmtp-1.0.6_2,1.log
https://keg.brnrd.eu/data/111amd64-default-openssl110/2018-08-17_12h10m13s/logs/errors/libesmtp-1.0.6_2,1.log

Did you build in poudriere or in a regular tree. I've seen differences there.
Comment 3 Nathan 2018-09-05 19:32:38 UTC
(In reply to Bernard Spil from comment #2)
Did it with poudriere. Specified OpenSSL-devel instead of uses=ssl
Comment 4 Nathan 2018-10-09 22:32:18 UTC
Created attachment 197983 [details]
Fix OpenSSL 1.1.x build

 mail/libesmtp: Fix OpenSSL build
 
 PR:             231931, 229017
 Submitted by:   Nathan <ndowens@yahoo.com>
 Approved by:    portmgr (unmaintained port)
Comment 5 Tobias Kortkamp freebsd_committer 2018-12-09 16:27:38 UTC
I do not think that this is a correct or complete patch.

client-ntlm.c:126:7: warning: this function declaration is not a prototype [-Wstrict-prototypes]
ntlmdes.c:58:3: warning: implicit declaration of function 'des_set_odd_parity' is invalid in C99 [-Wimplicit-function-declaration]
  des_set_odd_parity (&key);
  ^
ntlmdes.c:58:3: warning: this function declaration is not a prototype [-Wstrict-prototypes]
ntlmdes.c:59:3: warning: implicit declaration of function 'des_set_key' is invalid in C99 [-Wimplicit-function-declaration]
  des_set_key (&key, ks);
  ^
ntlmdes.c:59:3: warning: this function declaration is not a prototype [-Wstrict-prototypes]
ntlmdes.c:60:3: warning: implicit declaration of function 'des_ecb_encrypt' is invalid in C99 [-Wimplicit-function-declaration]
  des_ecb_encrypt (iv, result, ks, DES_ENCRYPT);
  ^
ntlmdes.c:60:3: warning: this function declaration is not a prototype [-Wstrict-prototypes]
ntlmdes.c:59:22: warning: variable 'ks' is uninitialized when used here [-Wuninitialized]
  des_set_key (&key, ks);
                     ^~
ntlmdes.c:36:3: note: variable 'ks' is declared here
  DES_key_schedule ks;

It also fails when using LDFLAGS+=-Wl,--no-undefined

 /usr/bin/ld: error: undefined symbol: des_set_odd_parity
 >>> referenced by ntlmdes.c
 >>>               .libs/ntlmdes.o:(lm_deshash)

 /usr/bin/ld: error: undefined symbol: des_set_key
 >>> referenced by ntlmdes.c
 >>>               .libs/ntlmdes.o:(lm_deshash)

 /usr/bin/ld: error: undefined symbol: des_ecb_encrypt
 >>> referenced by ntlmdes.c
 >>>               .libs/ntlmdes.o:(lm_deshash)
 cc: error: linker command failed with exit code 1 (use -v to see invocation)

For example, OpenSSL 1.1.1 no longer has des_set_key().  It's named
DES_set_key() there AFAICT.
Comment 6 Walter Schwarzenfeld freebsd_triage 2019-08-18 23:05:02 UTC

*** This bug has been marked as a duplicate of bug 238133 ***