Bug 229024 - sysutils/bacula-client: Fails to build with OpenSSL 1.1
Summary: sysutils/bacula-client: Fails to build with OpenSSL 1.1
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Dan Langille
URL:
Keywords:
Depends on:
Blocks: 228865
  Show dependency treegraph
 
Reported: 2018-06-14 20:08 UTC by Bernard Spil
Modified: 2019-03-03 11:37 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (dvl)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bernard Spil freebsd_committer 2018-06-14 20:08:13 UTC
> crypto.c:195:1: error: unknown type name 'IMPLEMENT_STACK_OF'

During BSDCan 2018 the intention to update OpenSSL in base to 1.1.x branch was documented.

Intention is to update 12-STABLE to current 1.1.0 and subsequently update it to 1.1.1 when that is released. 

Poudriere log: https://keg.brnrd.eu/data/111amd64-default-openssl110/2018-06-11_10h42m37s/logs/errors/bacula-client-7.4.7_2.log
Comment 1 Dan Langille freebsd_committer 2018-06-14 21:22:43 UTC
see also 228402: sysutils/bacula9-server: Fix build with LibreSSL 2.7
Comment 2 Dan Langille freebsd_committer 2019-02-25 22:06:39 UTC
sysutils/bacula-client is now deprecated.

I propose to not fix this issue because of that.
Comment 3 Rene Ladan freebsd_committer 2019-03-03 11:37:42 UTC
Expired port removed, please use sysutils/bacula9-client instead.