Bug 229101 - games/spring: fix build with CMake 3.12
Summary: games/spring: fix build with CMake 3.12
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Dmitry Marakasov
URL: https://reviews.freebsd.org/D15878
Keywords:
Depends on:
Blocks:
 
Reported: 2018-06-18 07:30 UTC by Adriaan de Groot
Modified: 2018-06-22 18:34 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (amdmi3)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adriaan de Groot freebsd_committer 2018-06-18 07:30:15 UTC
games/spring fails to build with CMake 3.12 (which we're about to exp-run). Patches are in https://reviews.freebsd.org/D15878
Comment 1 commit-hook freebsd_committer 2018-06-19 21:08:43 UTC
A commit references this bug:

Author: adridg
Date: Tue Jun 19 21:08:34 UTC 2018
New revision: 472823
URL: https://svnweb.freebsd.org/changeset/ports/472823

Log:
  Pre-emptively fix games/spring before CMake 3.12 arrives.

  file(GLOB .. FOLLOW_SYMLINKS ..) was never documented to work; in
  3.12-rc1 this has become an error. That in itself is considered
  a regression in CMake [1], but the use is wrong anyway, so patch
  it away. The change has been accepted upstream [2] already.

  Not bumping PORTREVISION because no code actually changes,
  it just removes a cmake-time no-op.

  [1] https://gitlab.kitware.com/cmake/cmake/issues/18097
  [2] https://springrts.com/mantis/view.php?id=6005

  PR:		229101
  Reviewed by:	tcberner
  Differential Revision:	https://reviews.freebsd.org/D15878

Changes:
  head/games/spring/files/patch-rts-build-cmake-Util
  head/games/spring/files/patch-rts-build-cmake-UtilJava