Bug 229259 - www/trac: nonoperability single project mode
Summary: www/trac: nonoperability single project mode
Status: Open
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Jochen Neumeister
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-06-23 21:30 UTC by ev
Modified: 2018-07-02 20:34 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (joneum)


Attachments
patch for files/tracd (1.93 KB, text/plain)
2018-06-23 21:30 UTC, ev
no flags Details
patch-files-tracd.in.diff (1.98 KB, patch)
2018-06-24 07:41 UTC, ev
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description ev 2018-06-23 21:30:41 UTC
Created attachment 194544 [details]
patch for files/tracd

When specifying tracd_env in /etc/rc.conf, an error occurs when tracd starts.
The reason is the use of the reserved variable ${name}_env from the system script /etc/rc.subr
This error also present in www/trac-devel.

The attached patch for files/tracd.in solves this problem.
Comment 1 Jochen Neumeister freebsd_committer 2018-06-24 06:47:06 UTC
Hey,
thank you for the PR. Can you please upload the Patch as diff? :-)
Comment 2 ev 2018-06-24 07:41:30 UTC
Created attachment 194550 [details]
patch-files-tracd.in.diff

That's correctly?
Comment 3 Jochen Neumeister freebsd_committer 2018-06-30 14:26:35 UTC
(In reply to ev from comment #2)
Hello :-)

yes it is better :-)
What irritates me right now: The version is already older. So far no one said the tracd did not start.
Comment 4 ev 2018-07-02 20:34:45 UTC
Found a similar problem in 2015
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=203037
Resolution: Unable to Reproduce

Perhaps the trac is not so popular, so there is not much feedback.