Bug 229273 - lang/polyml does not build -- upgrade to most recent version
Summary: lang/polyml does not build -- upgrade to most recent version
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Fernando Apesteguía
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-06-24 13:21 UTC by hannes
Modified: 2018-06-29 16:51 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (beyert)


Attachments
the diff for lang/polyml (1.66 KB, patch)
2018-06-24 13:21 UTC, hannes
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description hannes 2018-06-24 13:21:33 UTC
Created attachment 194560 [details]
the diff for lang/polyml

the port lang/polyml does no longer build (see #227296 for details).

Attached is a diff to upgrade to the most recent release, 5.7.1, which compiles and works fine.
Comment 1 Timothy Beyer 2018-06-26 16:27:48 UTC
approved.
Comment 2 Fernando Apesteguía freebsd_committer 2018-06-26 18:17:18 UTC
Take
Comment 3 commit-hook freebsd_committer 2018-06-29 16:48:21 UTC
A commit references this bug:

Author: fernape
Date: Fri Jun 29 16:48:11 UTC 2018
New revision: 473559
URL: https://svnweb.freebsd.org/changeset/ports/473559

Log:
  lang/polyml: update to 5.7.1

  Move some variables to its place.

  PR:	229273
  Reported by:	hannes@mehnert.org
  Approved by:	tcberner (mentor) beyert@cs.ucr.edu (maintainer)
  Differential Revision:	https://reviews.freebsd.org/D16022

Changes:
  head/lang/polyml/Makefile
  head/lang/polyml/distinfo
  head/lang/polyml/pkg-plist
Comment 4 Fernando Apesteguía freebsd_committer 2018-06-29 16:51:00 UTC
Commited,

Thanks!