Bug 229324 - emulators/qemu-devel : older than emulators/qemu, should it be removed?
Summary: emulators/qemu-devel : older than emulators/qemu, should it be removed?
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Muhammad Moinur Rahman
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-06-25 02:38 UTC by Rebecca Cran
Modified: 2019-03-05 23:30 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (bofh)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rebecca Cran freebsd_committer 2018-06-25 02:38:21 UTC
emulators/qemu-devel is:
  DISTVERSION=    2.6.0

But emulators/qemu is:
  PORTVERSION=    2.9.0

It should either be updated, or removed.
Comment 1 Muhammad Moinur Rahman freebsd_committer 2018-07-22 20:33:21 UTC
Working on 3.00-rc1.
Comment 2 commit-hook freebsd_committer 2019-02-28 01:52:33 UTC
A commit references this bug:

Author: bofh
Date: Thu Feb 28 01:52:19 UTC 2019
New revision: 494122
URL: https://svnweb.freebsd.org/changeset/ports/494122

Log:
  emulators/qemu-devel: Update version 2.6.0=>3.1.0

  PR:		229324
  Reported by:	bcran
  Relnotes:	https://www.qemu.org/2018/12/12/qemu-3-1-0/

Changes:
  head/emulators/qemu-devel/Makefile
  head/emulators/qemu-devel/distinfo
  head/emulators/qemu-devel/files/patch-Makefile
  head/emulators/qemu-devel/files/patch-configure
  head/emulators/qemu-devel/files/patch-include_qemu_atomic.h
  head/emulators/qemu-devel/files/patch-qemu-char.c
  head/emulators/qemu-devel/files/patch-slirp_slirp__config.h
  head/emulators/qemu-devel/files/patch-ui_x__keymap.c
  head/emulators/qemu-devel/files/pcap-patch
  head/emulators/qemu-devel/files/pcap-patch-net_clients.h
  head/emulators/qemu-devel/files/pcap-patch-net_net.c
  head/emulators/qemu-devel/files/pcap-patch-qapi_net.json
  head/emulators/qemu-devel/pkg-plist
Comment 3 John Hein 2019-03-05 20:01:54 UTC
What is driving the restriction for USES=ncurses:base (as opposed to just USES=ncurses)?  When I build with the ports version of ncurses, qemu-devel seems to build just fine.
Comment 4 Muhammad Moinur Rahman freebsd_committer 2019-03-05 20:06:19 UTC
(In reply to John Hein from comment #3)
Can't recollect the exact BUG id, but there was an issue where qemu would build with ncurses ports if it was installed and would give unprecedented result. That'w why we force ncurses:base,
Comment 5 John Hein 2019-03-05 22:52:22 UTC
(In reply to Muhammad Moinur Rahman from comment #4)
Thanks, if you remember the bug, let me know, and I'll check if it still applies.  I'll see if I can find it in bugzilla.

emulators/qemu builds fine with USES=ncurses (not just :base), too, by the way.
Comment 6 Muhammad Moinur Rahman freebsd_committer 2019-03-05 22:59:00 UTC
(In reply to John Hein from comment #5)
bug 211973
Comment 7 John Hein 2019-03-05 23:30:19 UTC
(In reply to Muhammad Moinur Rahman from comment #6)
Got it.  I think I see the problem.  It looks like it compiles with the port headers but is hard-coded (-L/usr/lib) to link with the curses lib in /usr/lib.  That behavior appears to have been introduced in 2017 (see r435826).

I'll see if I can work up a patch so it can work with either ncurses version.