Bug 229460 - x11-fonts/font-awesome: version bump - 5.1.0
Summary: x11-fonts/font-awesome: version bump - 5.1.0
Status: Closed DUPLICATE of bug 229619
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-01 23:17 UTC by Alexandre C. Guimarães
Modified: 2018-07-28 02:10 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (dmgk)


Attachments
Update to v5.1.0 (1.93 KB, patch)
2018-07-01 23:17 UTC, Alexandre C. Guimarães
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandre C. Guimarães freebsd_committer 2018-07-01 23:17:43 UTC
Created attachment 194821 [details]
Update to v5.1.0

Hi.

I attach a patch to build the new version.

The source seems to be just available on GitHub now (but with upstream prepared tarballs), and they also split desktop and web versions into separated packages.

The maintainer may be interested to re-work the port, flavoring or creating slave ports for them.

If any re-work will be done, I do suggest to change the port name to 'fontawesome-free' to avoid the need of set ${WRKSRC}, and also to be close of the upstream defaults.

Thanks!
Comment 1 Dmitri Goutnik freebsd_committer 2018-07-09 00:48:01 UTC
Alexandre,

Thank you for the patch. I don't see much sense in having a port for web fonts in the ports tree, software that needs them tends to have them vendored as a part of other web assets.

Port version should be bumped by bug #229619
Comment 2 Martin Wilke freebsd_committer 2018-07-28 02:10:08 UTC

*** This bug has been marked as a duplicate of bug 229619 ***