Bug 229570 - devel/llvm60: Ready for enabling OpenMP on 10.x?
Summary: devel/llvm60: Ready for enabling OpenMP on 10.x?
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Brooks Davis
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-06 15:56 UTC by Rainer Hurling
Modified: 2018-11-08 13:38 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (brooks)


Attachments
patch to enable all options on 10.x (341 bytes, patch)
2018-07-06 15:56 UTC, Rainer Hurling
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Hurling freebsd_committer 2018-07-06 15:56:10 UTC
Created attachment 194917 [details]
patch to enable all options on 10.x

After r473980[1], devel/llvm60 is ready for OpenMP on all FreeBSD versions, except for 10.x.

I tried the attached patch to remove the blocking line for 10.x, and 10.x seems to build functional OpenMP on both, amd64 and i386.



[1] https://svnweb.freebsd.org/ports?view=revision&revision=473980
Comment 1 commit-hook freebsd_committer 2018-09-20 02:47:39 UTC
A commit references this bug:

Author: brooks
Date: Thu Sep 20 02:47:24 UTC 2018
New revision: 480151
URL: https://svnweb.freebsd.org/changeset/ports/480151

Log:
  Update to LLVM 7.0.0 Release.

  Update LICENSE to include additional licenses of sub-components.

  Enable LLDB and OPENMP on 10. [0]

  PR:		229570 [0]
  Submitted by:	Rainer Hurling <rhurlin@gwdg.de> [0]
  Sponsored by:	DARPA, AFRL

Changes:
  head/devel/llvm70/Makefile
  head/devel/llvm70/distinfo
Comment 2 Tobias Kortkamp freebsd_committer 2018-11-08 13:38:21 UTC
FreeBSD 10 is EoL and the offending line is gone after ports r483807.