Bug 229705 - databases/clickhouse: fails to build with boost 1.68
Summary: databases/clickhouse: fails to build with boost 1.68
Status: Closed DUPLICATE of bug 230054
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords: needs-patch
Depends on:
Blocks: 229569
  Show dependency treegraph
 
Reported: 2018-07-11 16:10 UTC by Jan Beich
Modified: 2018-07-29 21:29 UTC (History)
1 user (show)

See Also:
jbeich: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2018-07-11 16:10:30 UTC
After bug 229569 lands this port will end up BROKEN. Can you help? I've already reported upstream.

In file included from dbms/src/Storages/MergeTree/MergeTreeDataSelectExecutor.cpp:1:
/usr/local/include/boost/rational.hpp:860:47: error: no member named 'max' in 'std::__1::numeric_limits<__uint128_t>'
    if (den < -(std::numeric_limits<IntType>::max)())
                                              ^
/usr/local/include/boost/rational.hpp:164:8: note: in instantiation of member function 'boost::rational<unsigned __int128>::normalize' requested here
       normalize();
       ^
/usr/local/include/boost/rational.hpp:252:23: note: in instantiation of function template specialization 'boost::rational<unsigned __int128>::rational<unsigned __int128, unsigned __int128>' requested here
       return *this = rational<IntType>(static_cast<IntType>(n), static_cast<IntType>(d));
                      ^
/usr/local/include/boost/rational.hpp:212:8: note: in instantiation of function template specialization 'boost::rational<unsigned __int128>::assign<int, int>' requested here
       assign(n, static_cast<T>(1));
       ^
dbms/src/Storages/MergeTree/MergeTreeDataSelectExecutor.cpp:124:16: note: in instantiation of function template specialization 'boost::rational<unsigned __int128>::rational<int>' requested here
        return 1;
               ^
1 error generated.
Comment 1 Jan Beich freebsd_committer 2018-07-11 16:18:04 UTC
In order to reproduce try the following:

$ fetch -qo- 'https://reviews.freebsd.org/D16165?download=true' | patch -Efsp0 -d /usr/ports
$ make all deinstall install clean -C/usr/ports/devel/boost-jam
$ make all deinstall install clean -C/usr/ports/devel/boost-libs
$ make -C /usr/ports/databases/clickhouse
Comment 2 proler 2018-07-16 11:48:31 UTC
https://github.com/yandex/ClickHouse/pull/2656/files
Will be fixed in next clickhouse release
Comment 3 Jan Beich freebsd_committer 2018-07-29 21:29:00 UTC
Thanks. Builds fine after ports r475667, see https://ptpb.pw/p1on

*** This bug has been marked as a duplicate of bug 230054 ***