Bug 229800 - multimedia/ffmpeg dependency on opencv pulls the huge tesseract library and data
Summary: multimedia/ffmpeg dependency on opencv pulls the huge tesseract library and data
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-multimedia mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-16 06:57 UTC by Ali Abdallah
Modified: 2018-07-18 21:45 UTC (History)
3 users (show)

See Also:


Attachments
Patch to make opencv-core not depend on tesseract (936 bytes, patch)
2018-07-16 16:33 UTC, Steve Wills
no flags Details | Diff
updated patch to fix opencv-core LIB_DEPENDS (886 bytes, patch)
2018-07-17 18:57 UTC, Steve Wills
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ali Abdallah 2018-07-16 06:57:33 UTC
Istalling firefox or iridium-browser pulls opencv which pulls the huge tessercat library and data. This is not okay for most people, especially when you are installing for the first time, and you quickly need a browser to access the forum/handbook for help.  

I would suggest to disable opencv option by default when building ffmpeg.
Comment 1 Steve Wills freebsd_committer 2018-07-16 16:17:06 UTC
Better solution might be to change opencv-core so that it doesn't depend on tesseract. Since ffmpeg depends on opencv-core and not opencv, this might solve the large dependency problem and not change any functionality. I'm testing a patch for this now.
Comment 2 Steve Wills freebsd_committer 2018-07-16 16:33:07 UTC
Created attachment 195175 [details]
Patch to make opencv-core not depend on tesseract

Here's the patch I'm testing.
Comment 3 Steve Wills freebsd_committer 2018-07-17 18:57:55 UTC
Created attachment 195208 [details]
updated patch to fix opencv-core LIB_DEPENDS

opencv-core only needs protobuf to build, so here's an updated version of the patch. Will commit this after some build tests finish.
Comment 4 Ali Abdallah 2018-07-17 19:24:20 UTC
Thanks very much for the quick fix!
Comment 5 commit-hook freebsd_committer 2018-07-18 12:53:48 UTC
A commit references this bug:

Author: swills
Date: Wed Jul 18 12:53:36 UTC 2018
New revision: 474860
URL: https://svnweb.freebsd.org/changeset/ports/474860

Log:
  graphics/opencv-core: remove unneeded depends

  opencv-core only needs protobuf to build and doesn't need tesseract at
  all, so only add the LIB_DEPENDS when not building opencv-core

  PR:		229800
  Reported by:	Ali Abdallah <aliovx@gmail.com>

Changes:
  head/graphics/opencv/Makefile
  head/graphics/opencv-core/Makefile
Comment 6 Steve Wills freebsd_committer 2018-07-18 12:55:29 UTC
Fix committed, thanks for reporting.
Comment 7 Jan Beich freebsd_committer 2018-07-18 21:45:36 UTC
Do you plan to MFH to 2018Q3? This maybe viewed as a regression since 3.x update.