Bug 229840 - security/py-cryptography: does not build with libressl
Summary: security/py-cryptography: does not build with libressl
Status: Closed DUPLICATE of bug 226906
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Kubilay Kocak
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-17 16:31 UTC by Dmitry Marakasov
Modified: 2018-08-05 23:44 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (koobs)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry Marakasov freebsd_committer 2018-07-17 16:31:02 UTC
...
build/temp.freebsd-11.2-RELEASE-amd64-2.7/_openssl.c:2345:6: error: conflicting types for 'X509_get0_signature'
void X509_get0_signature(ASN1_BIT_STRING **psig, X509_ALGOR **palg,
     ^
/usr/local/include/openssl/x509.h:919:6: note: previous declaration is here
void X509_get0_signature(const ASN1_BIT_STRING **psig,
     ^
build/temp.freebsd-11.2-RELEASE-amd64-2.7/_openssl.c:2479:7: error: redefinition of 'X509_VERIFY_PARAM_set1_host' as different kind of symbol
int (*X509_VERIFY_PARAM_set1_host)(X509_VERIFY_PARAM *, const char *,
      ^
...

Full log: https://people.freebsd.org/~amdmi3/pycryptograpy-libressl.log
Comment 1 cedric 2018-07-23 08:50:57 UTC
Duplicate of bug 226906
py-cryptography must be upgraded to version 2.3
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2018-08-05 23:44:15 UTC

*** This bug has been marked as a duplicate of bug 226906 ***