Bug 229854 (cmake-3.12.0) - [exp-run] Update cmake to 3.12.0
Summary: [exp-run] Update cmake to 3.12.0
Status: Closed FIXED
Alias: cmake-3.12.0
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Tobias C. Berner
URL:
Keywords:
: 229661 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-07-18 04:54 UTC by Tobias C. Berner
Modified: 2018-07-28 15:03 UTC (History)
2 users (show)

See Also:
antoine: exp-run+


Attachments
v1 (47.79 KB, patch)
2018-07-18 04:54 UTC, Tobias C. Berner
no flags Details | Diff
v2 (48.31 KB, patch)
2018-07-19 20:01 UTC, Tobias C. Berner
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias C. Berner freebsd_committer 2018-07-18 04:54:12 UTC
Created attachment 195228 [details]
v1

Hi there

kde@ would like to ask for an exp-run of cmake to 3.12.0.

The patch is attached, and can also be found here:
https://people.freebsd.org/~tcberner/patches/cmake-3.12.0.v1.diff


thanks and mfg 
Tobias
Comment 1 Tobias C. Berner freebsd_committer 2018-07-19 20:01:38 UTC
Here's a regenerated patch to match the current ports tree:
https://people.freebsd.org/~tcberner/patches/cmake-3.12.0.v2.diff
Comment 2 Tobias C. Berner freebsd_committer 2018-07-19 20:01:53 UTC
Created attachment 195281 [details]
v2
Comment 3 Jan Beich freebsd_committer 2018-07-20 01:07:31 UTC
*** Bug 229661 has been marked as a duplicate of this bug. ***
Comment 5 commit-hook freebsd_committer 2018-07-20 20:34:30 UTC
A commit references this bug:

Author: tcberner
Date: Fri Jul 20 20:34:06 UTC 2018
New revision: 475033
URL: https://svnweb.freebsd.org/changeset/ports/475033

Log:
  graphics/podofo: Add patch to fix build with upcomeing cmake-3.12

  The behaviour of cmake's copy_directory was changed, so that it
  now fails if the source directory does not exist.

  PR:		229854
  Reported by:	antoine

Changes:
  head/graphics/podofo/files/patch-test_TokenizerTest_CMakeLists.txt
Comment 6 commit-hook freebsd_committer 2018-07-20 20:46:42 UTC
A commit references this bug:

Author: tcberner
Date: Fri Jul 20 20:46:10 UTC 2018
New revision: 475034
URL: https://svnweb.freebsd.org/changeset/ports/475034

Log:
  net-im/psi: Add patches to fix build

  Add dependencies on the ui-gen target, this
  should fix the race condition during the build.

  PR:		229854
  Reported by:	antoine

Changes:
  head/net-im/psi/files/
  head/net-im/psi/files/patch-src_contactmanager_CMakeLists.txt
  head/net-im/psi/files/patch-src_sxe_CMakeLists.txt
Comment 7 commit-hook freebsd_committer 2018-07-20 21:24:15 UTC
A commit references this bug:

Author: tcberner
Date: Fri Jul 20 21:23:16 UTC 2018
New revision: 475037
URL: https://svnweb.freebsd.org/changeset/ports/475037

Log:
  science/paraview: Add patch to fix build with upcomeing cmake-3.12

  The behaviour of cmake's copy_directory was changed, so that it
  now fails if the source directory does not exist.

  Further add missing dependency on xmlpatterns.

  PR:		229854
  Reported by:	antoine

Changes:
  head/science/paraview/Makefile
  head/science/paraview/files/patch-CMake_ParaViewMacros.cmake
Comment 8 Antoine Brodin freebsd_committer 2018-07-24 08:48:08 UTC
Exp-run looks fine.
Comment 9 commit-hook freebsd_committer 2018-07-28 15:02:31 UTC
A commit references this bug:

Author: tcberner
Date: Sat Jul 28 15:01:55 UTC 2018
New revision: 475584
URL: https://svnweb.freebsd.org/changeset/ports/475584

Log:
  Update devel/cmake* to 3.12.0

  Exp-run by:	antoine
  PR:		229854

Changes:
  head/devel/cmake/Makefile
  head/devel/cmake/distinfo
  head/devel/cmake/files/patch-Modules_FindLua.cmake
  head/devel/cmake/files/patch-Modules_FindQt4.cmake
  head/devel/cmake/files/patch-Source_Modules_FindLibUV.cmake
  head/devel/cmake/pkg-plist
  head/devel/cmake-doc/Makefile
  head/devel/cmake-doc/pkg-plist
  head/devel/cmake-gui/Makefile
  head/devel/cmake-gui/files/
Comment 10 Tobias C. Berner freebsd_committer 2018-07-28 15:03:10 UTC
Thanks for the exp-run.