Bug 229874 - graphics/fracplanet: Update to 0.5.1
Summary: graphics/fracplanet: Update to 0.5.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Steve Wills
URL:
Keywords:
: 216060 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-07-18 20:56 UTC by Kai Knoblich
Modified: 2018-08-05 21:00 UTC (History)
1 user (show)

See Also:


Attachments
fracplanet-0.5.1.patch (6.08 KB, patch)
2018-07-18 20:56 UTC, Kai Knoblich
kai: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kai Knoblich freebsd_committer 2018-07-18 20:56:33 UTC
Created attachment 195259 [details]
fracplanet-0.5.1.patch

Hello,

attached is the patch that updates graphics/fracplanet to 0.5.1 . 

Changes by upstream (taken from NEWS):
Release 0.5.1:
 - Rename BUILD to BUILD.sh; ditch configure; move built-in USAGE processing to USAGE-update.sh and put usage_text.h under version control.
 - Some tweaks to code; split Qt includes from common.h to qtcommon.h

Release 0.5.0:
 - Verified works with Qt 5.9.1 ("official" Qt release) and g++ 6.3.0 (Debian Stretch version)
 - Ditch use of precompiled headers; compilers are awesome these days.
 - Increase initial subdivision level to 8.


Changes to the port:
- added FLAVORS to create Qt4/Qt5 packages
- sorted variables
- converted to new OPTIONS framework
- supplied patches in files/ are no longer required


QA:
~~~
- poudriere (10.4-, 11.1-, 11.2-RELEASE and 12.0-CURRENT @r336303) for each amd64 + i386 archs -> OK
- portlint -> OK

Note:
- a test build on 11.2-RELEASE with devel/boost-all 1.68 (see also: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=229569) was fine
- a test build on 11.2-RELEASE with lang/gcc6 or later still fails (see also: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=216060)
Comment 1 Steve Wills freebsd_committer 2018-07-20 16:23:42 UTC
Committed, thanks!
Comment 2 commit-hook freebsd_committer 2018-07-20 16:30:15 UTC
A commit references this bug:

Author: swills
Date: Fri Jul 20 16:29:35 UTC 2018
New revision: 475027
URL: https://svnweb.freebsd.org/changeset/ports/475027

Log:
  graphics/fracplanet: update to 0.5.1

  PR:		229874
  Submitted by:	Kai <freebsd_ports@k-worx.org>
  Approved by:	portmgr (implicit)

Changes:
  head/graphics/fracplanet/Makefile
  head/graphics/fracplanet/distinfo
  head/graphics/fracplanet/files/
Comment 3 Jan Beich freebsd_committer 2018-08-05 21:00:46 UTC
*** Bug 216060 has been marked as a duplicate of this bug. ***