Bug 229891 - devel/lua-stdlib-normalize: bad version assumptions break DOCS
Summary: devel/lua-stdlib-normalize: bad version assumptions break DOCS
Status: Closed DUPLICATE of bug 231733
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-19 20:20 UTC by andrew
Modified: 2019-08-26 18:05 UTC (History)
2 users (show)

See Also:
sasaki: maintainer-feedback+


Attachments
Patch fixing DOCS (1.89 KB, patch)
2018-07-20 09:11 UTC, Kan Sasaki
no flags Details | Diff
Suggested alternative patch (3.01 KB, patch)
2018-07-21 06:30 UTC, andrew
no flags Details | Diff
Patch fixing DOCS (2.15 KB, patch)
2018-07-21 15:38 UTC, Kan Sasaki
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description andrew 2018-07-19 20:20:17 UTC
The DOCS option is broken on Lua versions other than 5.2 (which was EOLed 3 years ago) because the pkg-plist thinks it can hardcode the package name. Same bug is in lua-stdlib-debug.
Comment 1 Kan Sasaki 2018-07-20 09:11:00 UTC
Created attachment 195298 [details]
Patch fixing DOCS

Move documents under %%PORTDOCS%%%%DOCSDIR%%.
Comment 2 andrew 2018-07-21 02:45:36 UTC
(In reply to Kan Sasaki from comment #1)

That doesn't look right since it makes the docs dir not depend on the Lua version, causing a conflict if you try and install the port multiple times for different versions.
Comment 3 andrew 2018-07-21 06:30:38 UTC
Created attachment 195320 [details]
Suggested alternative patch

As for -debug, I would suggest deleting the pkg-plist entirely - it's more trouble than it's worth for a trivial port like this - and do the work in the makefile as per the attached patch.
Comment 4 Kan Sasaki 2018-07-21 15:38:07 UTC
Created attachment 195338 [details]
Patch fixing DOCS

Move docs under doc/${PKGNAMEPREFIX}${PORTNAME}. I have tested with 5.2 and 5.3.

I think the doc directory for this should be defined in .mk file such as lua.mk and docs should be placed under doc/lua${LUA_VER_STR}/${PORTNAME} like a ruby module.
However, it will be a little big change, so I defined DOCSDIR at this time.
Comment 5 andrew 2018-07-21 15:53:11 UTC
(In reply to Kan Sasaki from comment #4)

I'm working with russ on updating the lua ports (for 5.3.5 and 5.4.0-work), the next versions of which will likely install the docs for Lua itself in doc/lua53 etc. That wouldn't work too well with your idea, but we could make the Lua port install docs in doc/lua53/lua so that modules can use doc/lua53/${PORTNAME} or similar.
Comment 6 Walter Schwarzenfeld freebsd_triage 2019-08-26 18:05:03 UTC

*** This bug has been marked as a duplicate of bug 231733 ***