Bug 229892 - devel/lua-stdlib-debug: bad version assumptions break DOCS
Summary: devel/lua-stdlib-debug: bad version assumptions break DOCS
Status: Closed DUPLICATE of bug 231734
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-19 20:22 UTC by andrew
Modified: 2019-08-26 18:03 UTC (History)
2 users (show)

See Also:
sasaki: maintainer-feedback+


Attachments
Patch fixing DOCS (1.80 KB, patch)
2018-07-20 09:10 UTC, Kan Sasaki
no flags Details | Diff
Suggested alternative patch (2.52 KB, patch)
2018-07-21 06:25 UTC, andrew
no flags Details | Diff
Patch fixing DOCS (2.06 KB, patch)
2018-07-21 15:37 UTC, Kan Sasaki
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description andrew 2018-07-19 20:22:53 UTC
The DOCS option is broken on Lua versions other than 5.2 (which was EOLed 3 years ago) because the pkg-plist thinks it can hardcode the package name. Same bug is in lua-stdlib-normalize.
Comment 1 Kan Sasaki 2018-07-20 09:10:47 UTC
Created attachment 195297 [details]
Patch fixing DOCS

Move documents under %%PORTDOCS%%%%DOCSDIR%%.
Comment 2 andrew 2018-07-21 06:25:03 UTC
Created attachment 195319 [details]
Suggested alternative patch

That patch above is wrong for the same reasons as the equivalent patch for -normalize; it's making the docs location independent of Lua version, causing conflicts.

I would suggest deleting the pkg-plist entirely - it's more trouble than it's worth for a trivial port like these - and do the work in the makefile as per the attached patch.
Comment 3 Kan Sasaki 2018-07-21 15:37:37 UTC
Created attachment 195337 [details]
Patch fixing DOCS

Move docs under doc/${PKGNAMEPREFIX}${PORTNAME}. I have tested with 5.2 and 5.3.

I think the doc directory for this should be defined in .mk file such as lua.mk and docs should be placed under doc/lua${LUA_VER_STR}/${PORTNAME} like a ruby module.
However, it will be a little big change, so I defined DOCSDIR at this time.
Comment 4 Walter Schwarzenfeld freebsd_triage 2019-08-26 18:03:07 UTC

*** This bug has been marked as a duplicate of bug 231734 ***