Bug 229915 - graphics/py-pygal: Update to 2.4.0
Summary: graphics/py-pygal: Update to 2.4.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Kai Knoblich
URL: https://github.com/Kozea/pygal/blob/2...
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-20 23:39 UTC by jjachuf
Modified: 2019-06-09 14:16 UTC (History)
2 users (show)

See Also:


Attachments
patch (915 bytes, text/plain)
2018-07-20 23:39 UTC, jjachuf
kai: maintainer-approval+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jjachuf 2018-07-20 23:39:39 UTC
Created attachment 195313 [details]
patch

simple version upgrade (2.3.1 to 2.4.0)
Comment 1 Martin Wilke freebsd_committer 2018-07-28 14:47:27 UTC
Hi,

I am getting belows error:

===>   py27-pygal-2.4.0 depends on file: /usr/local/bin/python2.7 - found
===>  Configuring for py27-pygal-2.4.0
Download error on https://pypi.org/simple/pytest-runner/: [Errno 8] hostname nor servname provided, or not known -- Some packages may not be found!
Couldn't find index page for 'pytest-runner' (maybe misspelled?)
Download error on https://pypi.org/simple/: [Errno 8] hostname nor servname provided, or not known -- Some packages may not be found!
No local packages or working download links found for pytest-runner
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "setup.py", line 96, in <module>
    "Topic :: Multimedia :: Graphics :: Presentation"])
  File "/usr/local/lib/python2.7/site-packages/setuptools/__init__.py", line 130, in setup
    _install_setup_requires(attrs)
  File "/usr/local/lib/python2.7/site-packages/setuptools/__init__.py", line 125, in _install_setup_requires
    dist.fetch_build_eggs(dist.setup_requires)
  File "/usr/local/lib/python2.7/site-packages/setuptools/dist.py", line 514, in fetch_build_eggs
    replace_conflicting=True,
  File "/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 773, in resolve
    replace_conflicting=replace_conflicting
  File "/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 1056, in best_match
    return self.obtain(req, installer)
  File "/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 1068, in obtain
    return installer(requirement)
  File "/usr/local/lib/python2.7/site-packages/setuptools/dist.py", line 581, in fetch_build_egg
    return cmd.easy_install(req)
  File "/usr/local/lib/python2.7/site-packages/setuptools/command/easy_install.py", line 670, in easy_install
    raise DistutilsError(msg)
distutils.errors.DistutilsError: Could not find suitable distribution for Requirement.parse('pytest-runner')
*** Error code 1
Comment 2 commit-hook freebsd_committer 2019-06-09 14:10:24 UTC
A commit references this bug:

Author: kai
Date: Sun Jun  9 14:10:07 UTC 2019
New revision: 503821
URL: https://svnweb.freebsd.org/changeset/ports/503821

Log:
  graphics/py-pygal: Update to 2.4.0

  While I'm here:
  * Pet portlint

  PR:		229915
  Submitted by:	jjachuf@gmail.com (maintainer)

Changes:
  head/graphics/py-pygal/Makefile
  head/graphics/py-pygal/distinfo
Comment 3 Kai Knoblich freebsd_committer 2019-06-09 14:12:19 UTC
Committed, thanks!