Bug 229950 - databases/mysql++3: Fix build with MariaDB 10.2
Summary: databases/mysql++3: Fix build with MariaDB 10.2
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Jochen Neumeister
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-22 07:07 UTC by Ting-Wei Lan
Modified: 2018-08-04 11:43 UTC (History)
2 users (show)

See Also:


Attachments
Fix build with MariaDB 10.2 (859 bytes, patch)
2018-07-22 07:07 UTC, Ting-Wei Lan
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ting-Wei Lan 2018-07-22 07:07:14 UTC
Created attachment 195362 [details]
Fix build with MariaDB 10.2

Currently MySQL++ 3 doesn't build with MariaDB 10.2:

./lib/dbdriver.cpp:260:10: error: use of undeclared identifier 'CLIENT_LONG_PASSWORD'
                        (o >= CLIENT_LONG_PASSWORD) &&
                              ^
1 warning and 1 error generated.
gmake[1]: *** [Makefile:545: mysqlpp_dbdriver.o] Error 1

The patch to fix the problem is already accepted by the upstream, but there is no released version of MySQL++ 3 including the fix.
Comment 1 Jochen Neumeister freebsd_committer 2018-07-29 12:56:08 UTC
Landed. Thanks :-)
Comment 2 commit-hook freebsd_committer 2018-07-29 12:56:25 UTC
A commit references this bug:

Author: joneum
Date: Sun Jul 29 12:55:56 UTC 2018
New revision: 475659
URL: https://svnweb.freebsd.org/changeset/ports/475659

Log:
  databases/mysql++3: Fix build with MariaDB 10.2

  ./lib/dbdriver.cpp:260:10: error: use of undeclared identifier 'CLIENT_LONG_PASSWORD'
                          (o >= CLIENT_LONG_PASSWORD) &&
                                ^
  1 warning and 1 error generated.
  gmake[1]: *** [Makefile:545: mysqlpp_dbdriver.o] Error 1

  PR:		229950
  Submitted by:	Ting-Wei Lan <lantw44@gmail.com> (maintainer)

Changes:
  head/databases/mysql++3/files/patch-lib_dbdriver.cpp
Comment 3 Warren Young 2018-08-04 11:43:07 UTC
MySQL++ 3.2.4 is out with this fix and more.