Bug 229961 - [update] devel/libconfig: update to 1.7.2
Summary: [update] devel/libconfig: update to 1.7.2
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Fernando Apesteguía
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-22 15:10 UTC by Maxim Filimonov
Modified: 2018-08-26 15:31 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (ntarmos)


Attachments
the patch (1.98 KB, patch)
2018-07-22 15:10 UTC, Maxim Filimonov
no flags Details | Diff
poudriere log (31.98 KB, text/plain)
2018-07-22 15:13 UTC, Maxim Filimonov
no flags Details
the patch [2] (2.01 KB, patch)
2018-07-22 15:21 UTC, Maxim Filimonov
no flags Details | Diff
Proposed patch (2.21 KB, patch)
2018-07-25 16:02 UTC, Fernando Apesteguía
fernape: maintainer-approval?
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Maxim Filimonov 2018-07-22 15:10:35 UTC
Created attachment 195368 [details]
the patch
Comment 1 Maxim Filimonov 2018-07-22 15:11:09 UTC
The port needs an update.
Warning: may break things (presumably tox). The poudriere log follows.
Comment 2 Maxim Filimonov 2018-07-22 15:13:18 UTC
Created attachment 195369 [details]
poudriere log
Comment 3 Maxim Filimonov 2018-07-22 15:21:11 UTC
Created attachment 195372 [details]
the patch [2]
Comment 4 Fernando Apesteguía freebsd_committer 2018-07-23 21:07:08 UTC
Take
Comment 5 Fernando Apesteguía freebsd_committer 2018-07-24 15:53:51 UTC
Hi Maxim,

Thanks for the patch :-)

I have a question though: is the update correct? the static library is not built anymore and the shared library changes its name from libconfig to liblibconfig
Comment 6 Maxim Filimonov 2018-07-25 10:13:18 UTC
Hello Fernando,

Well, I didn't patch it much, so it does exactly what it does. Didn't find the .a file anywhere, and poudriere doesn't say there are any orphaned files in the staging dir. Might have to patch it, tho; the only problem is, I don't know what exactly to patch yet.
Comment 7 Fernando Apesteguía freebsd_committer 2018-07-25 16:02:12 UTC
Created attachment 195449 [details]
Proposed patch

New patch that uses GNU autotools for building.
Comment 8 Fernando Apesteguía freebsd_committer 2018-07-25 16:03:59 UTC
(In reply to Maxim Filimonov from comment #6)
The problem is that the change in the name can cause breakage. I don't know why the CMake build does that, but if building with GNU autotools, the generated artifacts are similar to the ones generated before (libconfig.so instead of liblibconfig.so, libconfig.a generated too...).

So I propose a new patch to update the port.

Cheers
Comment 9 Maxim Filimonov 2018-07-25 21:33:02 UTC
I could patch the CMake configs so that they'd provide the same artifacts.
Comment 10 Fernando Apesteguía freebsd_committer 2018-07-26 15:10:43 UTC
(In reply to Maxim Filimonov from comment #9)
I rather avoid adding patches to the port. Building with GNU autotools seems to work fine out of the box.
Comment 11 commit-hook freebsd_committer 2018-08-06 17:23:08 UTC
A commit references this bug:

Author: fernape
Date: Mon Aug  6 17:22:41 UTC 2018
New revision: 476517
URL: https://svnweb.freebsd.org/changeset/ports/476517

Log:
  devel/libconfig: update to 1.7.2

  * Change to USE_GH
  * Bump PORTREVISION of dependant ports.

  Committing after maintainer timeout

  PR:	229961
  Submitted by:	che@bein.link
  Approved by:	tcberner (mentor)
  Differential Revision:	https://reviews.freebsd.org/D16442

Changes:
  head/astro/siril/Makefile
  head/audio/shairport-sync/Makefile
  head/audio/umurmur/Makefile
  head/databases/ateam_mysql_ldap_auth/Makefile
  head/databases/zabbix22-libzbxpgsql/Makefile
  head/databases/zabbix3-libzbxpgsql/Makefile
  head/databases/zabbix32-libzbxpgsql/Makefile
  head/databases/zabbix34-libzbxpgsql/Makefile
  head/devel/libconfig/Makefile
  head/devel/libconfig/distinfo
  head/devel/libconfig/pkg-plist
  head/lang/ldc/Makefile
  head/net/sslh/Makefile
  head/net-im/telegram/Makefile
  head/net-im/tox/Makefile
  head/net-im/toxic/Makefile
  head/security/cvechecker/Makefile
  head/security/razorback-api/Makefile
  head/x11-wm/compton/Makefile