Bug 229981 - sysutils/py-salt: salt_proxy startup script breaks PYTHON_EGG_CACHE config
Summary: sysutils/py-salt: salt_proxy startup script breaks PYTHON_EGG_CACHE config
Status: Closed DUPLICATE of bug 236184
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-23 14:45 UTC by Nick Hilliard
Modified: 2019-03-04 13:03 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (christer.edwards)


Attachments
fix for salt_proxy startup problem (420 bytes, patch)
2018-07-23 14:45 UTC, Nick Hilliard
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Hilliard 2018-07-23 14:45:08 UTC
Created attachment 195389 [details]
fix for salt_proxy startup problem

A recent upgrade to python has unearthed a problem with the salt_proxy startup script.  The script references ${salt_minion_paths} and ${salt_minion_eggcache}, but these are both undefined variables, which causes the script to fail.  Instead, the script should use ${salt_proxy_paths} and ${salt_proxy_eggcache}.

fix attached below.
Comment 1 Nathan 2018-08-26 06:42:37 UTC
I'm still getting that error with patch
Comment 2 Nick Hilliard 2019-03-04 13:03:08 UTC

*** This bug has been marked as a duplicate of bug 236184 ***